Servers by jDrones

Undetected 2nd GPS when auto_config=0


(Clement Fpv) #1

Hello, I need to output UBLX+NMEA from one of my two gps for another component of my plane that needs nmea.
Therefore I configured one gps to output both protocols and disabled gps auto config in arduplane. In this scenario the 2nd gps (serial 4) is undetected even tough it is outputting the same thing that what’s configured usually by the pixhawk.

If there is no way to fix that, is it possible to make the pixhawk configure UBLX+NMEA on auto config ?

Thanks


(WickedShell) #2

There is no way to enable both NMEA and UBlox output automatically on the GPS. Your second GPS may not be fully configured correctly. You could try disconnecting the first GPS you have manually configured, connect just the second set GPS_AUTO_CONFIG 1 and set GPS_SAVE_CFG 2 to save the auto configuration results. After booting and letting this GPS be fully configured (and settings saved). You could revert these parameters and try again.

I should note that any startup errors/misconfiguration of the GPS will not be detected if GPS_AUTO_CONFIG is not enabled.


(Clement Fpv) #3

Hi, thanks for your help, actually I got it working using a similar module as the second gps than the first one.
At the moment I did gps_save_cfg=2 on the second gps to be sure it is set properly.