Servers by jDrones

Uncontrolled yaw and crash on HJ Y3 tricopter (ArduCopter 3.5.5)

Hello,

Today I was testing (the third test flight) my HJ Y3 tricopter (AC3.5.5 on PixRacer, Beitian BN-880 GPS, APM power module, BLHeli 30A ESC with BEC, SkyRC X2830/950kV motors, 4S 25C 3500mAh battery, Matek MicroPDB). The previous two flights were successful (the second one was an Autotune session that never completed and I had to abort it due to low voltage). Here are some pictures of the frame showing how the PixRacer is mounted (using a vibration damper base):
Picture 1
Picture 2
Picture 3
Picture 4
Picture 5

This is my first ever tricopter, in the past I had great success with ArduCopter on quadcopters (an S500 and a CX-20 which I upgraded to a PixRacer).

On the third flight - while at PosHold mode - about 4 minutes after taking off, the tricopter entered an uncontrolled yaw state that made it spin frantically. The battery was fully charged and new (less than 3 charge cycles). It forced me to use the kill motors switch to bring it down (no damage done as I was flying over a football field, less than 10 meters from the surface). A quick check of the dataflash log did not show any indications of extreme vibrations (excluding the actual crash, FC vibrations are well within the advised limits).

I was hoping that someone with more experience with tricopters and ArduCopter in general could check my dataflash log and provide an explanation what went wrong (and some advice); I am really afraid to fly it again because I cannot understand what went wrong, even if it is still flying like before the crash.

I am attaching my dataflash log and my parameters file.
Thank you very much in advance.

HJ_Y3.param (13.4 KB)
HJ Y3 Dataflash log (tried to upload the file here but was rejected due to it’s size, even if it is only 1.1MB).
HJ-Y3 dataflash log (alternative hoster)

Sorry, I don’t give my email to hosters, so I couldn’t download your log.

Can you try this one please?

I find the most telling log values are the RCout which you are unfortunately not logging.

Just before the yaw went crazy there was a yaw ‘glitch’ that was not commanded by RC.
And I note that yaw precedes DesYaw.
Could the yaw servo have failed?

Thank you very much Mike for taking the time to view the log.

The tail servo after the crash continues to move like normal, so I cannot tell if it is in a ‘failed’ state or not.

When the weather calms down, I will try to do another flight at the football field, this time with RCIN logging enabled… and hoping that it will not crash.

I use Mission Planner for reviewing my logs and I’ve noticed that near at the end there is an “Autotune” labed right where it should be “PosHold” mode. I am pretty sure that I did not switch on AutoTune at that time and this puzzles me why it is being reported.

Manos,

I think RCOut are the values that provide the greatest insights…

Christian

I will add RCout also Christian to the log and post back, thank you.

The TX used is the Taranis X9D+ (OpenTX 2.1.5) together with the XSR+ RX, pretty standard configuration (I use the same parts on my racers too). The XSR+ is connected both to the PixRacer RC port and FrSky telemetry port.

I don’t have too much time to analyze right now, and I don’t have experience with tricopters, but I noticed that your PIDs seem unstable. We don’t have RCOUT, but we do have RATE fields, which show the roll, pitch, yaw, and throttle accelerations that the flight controller wants:

All three rotational axes have a significant periodic oscillation. It’s low frequency, so maybe I term overshoot. There are two significant events, both involving yaw:

This is the first one. As you can see, yaw begins an unstable growing oscillation. I’m not sure how it recovered from it the first time, but when it happened again, the copter crashed.

This can be a result of poor tuning, or possibly also mechanical issues. For example, lag or slop in the yaw servo could probably produce such a result, or if it’s not strong enough. It might be worth investigating the yaw servo. A sloppy servo could also possibly explain the smaller constant oscillations.

Thank you Rick for your insight.

I am pretty sure that regarding vibrations, the tricopter is OK since I use the same damping board type with my S500 quadcopter (vibrations on S500 PixRacer are lower than 10 units). It could be that there is some kind of issue with the tail servo, as I am totally unfamiliar with tricopters. The servo is a 90g one, as it came with the HJ-Y3 kit (it is not a digital servo). The blades are also DJI 9450 (balanced) self-tightening, so no problems there.

PIDs used are the stock Y3 ones as it was impossible to complete the autotune session due to the first battery running out (I was trying to tune roll and pitch and even after 15 minutes in PosHold it still failed to complete).

Do you see anything wrong regarding the default SERVO5 PPM values on my .param file?

Thank you very much in advance.

Yesterday I’ve performed another flight (actually two of them) after changing the yaw servo with a new 90g MGS one and new motors (RacerStar 2212 920kV).

On the first flight, I’ve performed Autotune (in GPS PosHold mode) successfully on yaw, roll and pitch (one axis at a time) which turned out just fine (attaching the new .param file with PIDs from autotune). After changing the battery, I decided to fly again: less than two minutes after taking off, the tricopter entered an uncontrolled yaw state and crashed (this time only the 3D printed landing gear was broken).

I am attaching the new dataflash log from the flight, now with RCOut logged also. Prior to yaw spinning, I do not see anything wrong with RCout.

I really do not understand what is going wrong with this tricopter :frowning:
Is there anything else I can do to save this build or should I just dismantle it and forget it?

Many thanks in advance for any help.

Dataflash log
Y3_AC355_PixRacer_Autotune.param (13.5 KB)

Your Yaw servo is not up to the task.
Either it is not strong enough, too slow, or the linkages have too much free play.
You can see here the FC trying to correct for the yaw oscillation.


And here the Rout trying to drive the servo until it cannot give it anymore.

You need to look at your mechanical yaw setup and the servo you use.
It could be your servo is too slow.

Thank you Mike for taking the time to do this analysis.

I have zero experience about servos, I understand the “90g” specification has to do with power but besides that nothing else.

1 Like

Anny news about the tree copter?

No, I have dismantled the tricopter since then and never tried to rebuild it.

Servers by jDrones