Uncontrollable throttle increase


I’ve been putting together a hexacopter using a pixhawk cube and when I increase throttle to 10%, the motors uncontrollable begin to increase until I bring it back down to 0%. I’ve been troubleshooting for a while, and here’s some things I’ve found out:

  • It doesn’t happen when the props are removed
  • I re-wired the ESCs to go directly to the receiver (instead of through the Pixhawk) and did not have the issue, so I’ve isolated the issue to being within the Pixhawk/Mission planner
  • While flying, the copter also yaws uncontrollably ccw. Not sure if this is related or not

I’ve tried changing various settings within Mission Planner and the transmitter itself, but nothing has worked and I can’t find anything online. Any ideas/help would be appreciated.

If you post a .bin flight log from the Cube it will give us something to go on.

Are you testing this on the bench? If so what you describe is normal. It doesn’t make sense that the props on or off would make any difference in this regard.

have you check your props ?

Sound 1 or 2 props are not in correct direction.