Servers by jDrones

Uncommon motor behavior changing mode

Hi,

I upgraded my vtol from arduplane 3.9 to V4.1.0dev and after reconfiguring everything I found this uncommon behavior.
After arming in FBWA or QSTABILIZE everything os working as expected, but when I change to manual mode the tilt motors are upforwarding but just the left motor are ok, the right motor is just off as you can see on this video: https://youtu.be/P9zjcS-c47Q
With arduplane 3.9 evevething was working fine.

Thanks for help.

Post your question in this thread

I think there are some issues with new release.

Thanks man.

I will post there.

I updated the code for the new 4.0.6 version.

First detail is I’m using an order for servo ouputs not usual.
Servo1 - Motor 3
Servo2 - Aileron
Servo3 - Servo tilt - Left
Servo4 - Motor 2
Servo5 - Motor 1
Servo6 - Aileron
Servo7 - Servo tilt Right
Servo8 - Motor 4

I was digging the logs and one more detail, if I switch from manual to FBWA mode, the motor 3 is the only spin, the motor 1 don’t spin like the behavior expected in manual mode.
I ran the motor test and all motors looking good.

Any clue ?

Can you download the latest version of MP.

It has over 360 fixes.

I will check your post, stuck in meetings.

Q_TILT_MASK should be 3, need logs to be any more help

Hi @iampete,

according the tilt rotor doc, the number of Q_TILT_MASK should by a simple sum of the motors, in my case the motors 3 and 1, so I configured as 4.
Doind the config you point me (3), the behavior was inverted, the right motor was spinning and the left motor was stopped, then I configured with 5 and than, the front motors was spinning right.
Now I’m confusing about how to use the Q_TILT_MASK parameter, because in the page (https://ardupilot.org/plane/docs/guide-tilt-rotor.html) is telling a sum, but the value 5 is the bitmask for motors 3 and 1.

This is a log as you asked for, but for now is ok with 5.

Ah that explains it, I saw 2 motors and assumed one at the back for a tricopter. You actually have a quad so motors 3 and 1 should tilt. The bitmask is zero indexed so 3 becomes bit 2 and 1 is bit 0. So the maths is 2^0 + 2^2 = 5. If you update mission planner you should get nice ticky boxes so you can just tick the motors you need and skip the maths.

hi @iampete
yes, I don’t know why, but I made a mistake with bimask with sum ( :see_no_evil: ) stupid mistake :smiley:
thanks for point me, and in my mind the tilt bitmask just deal with servos and not the motors, now I know the correct and expected behavior parameter :slight_smile:
thanks again

Servers by jDrones