Uncommanded Yaw with 3.5


i’m really not sure if this is a problem with my rig or if it is some problem with 3.5 rc-2 in my case.

I’m getting some strange behaviour during flight. The Hex turns left in the yaw axis a couple of degrees. And with a couple I mean like 30 to 45.
It is something new i’m getting with this hex. Flying this one for like 3 years now. So someone can maybe point me in the right direction to find the problem.

First of all: I don’t think this is a compass related problem. Got this behaviour with two different gps/compass modules after redoing all the calibrations. Onboard Compass, Compass/Mot, Accel Calibration. I performed even ESC calibration to get rid of the problem which cost me 6 props already…

Feel free to suggest anything
00000060.BIN (1.3 MB)

Tagging @rmackay9 in this

A surprising snappy quick yaw, or slow rate to one side you did not intend?

I think it’s odd that your yaw input (RCIN CH4) is never quite centered (1500) in flight. I didn’t look up the dead zone figure. It is centered at the beginning and end of log. Are you introducing yaw trim in the transmitter, then removing it?

It’s more like a slow turn. It looks for me more like a not quite accurate leveled motor pod but they are all fine. The yaw is much faster if gaining altitude.

The stick was never really centered because i worked against the yaw to maintain maneuverability. I lost some props so far due to dynamic roll-over during landing. this was to prevent that

So i guess nobody has any idea, why the copter is failing?

Have you loaded the latest 3.5-RCx?

Have had something similar but it appeared to be due to one of the compasses being out by 180deg.

Have you tried turning on “learn offsets”?

I have the same problem. When turning it sometimes agressively yaws in the opposite direction for a moment

Did after upgrading the compass calibration. so i assume this is not compass related.

Has anyone the same problem before 3.5 ?