Unable to trigger RTL from Radio's failsafe


I have an odd behaviour from FrSky Taranis (Open Tx 2.1.x) and Ardupilot Copter 3.3.

I have a dedicated switch for Failsafe (CH7) and it works well when I activate it manually.

However, when I set up a custom failsafe on Taranis to send exactly the same channel positions in case of failure, Ardupilot simply ignore it and never enter in RTL.

I have attached some MP captures showing the FS screen and channel status.

Do you have any idea what’s happening? I really want to use the radio FS option as it is easier to change on field.

Answering my own question for those who suffer from the same problem

The SBUS protocol has a “failsafe” flag. If you’re using SBUS to communicate to FC, no matter what setting you make on your receiver, Ardupilot will “hold” all channels and do what’s set up on the FS_THR_ENABLE option.

If you set it to disabled, you’re going to have a flyaway, as the FC will hold last commands until your battery drains

Ok, sounds like you’ve got it sorted out so I’ve marked the issue as resolved.

Really you shouldn’t be relying on the receiver to invoke the failsafe behaviour. Instead follow the instructions on the wiki so that the receiver tells the autopilot that it’s lost connect and then let the autopilot do what’ it’s been configured to do. copter.ardupilot.com/wiki/throttle-failsafe/

All modern receivers can be setup to tell the autopilot it’s lost connection either by pulling the throttle channel below it’s normal range or it can completely stop sending updates.

I have always used the “No Pulse” option on Sbus receivers. I always test failsafe on the ground and then once in the air by turning off the transmitter to make sure it works. I have never had any problems using that method.