Unable to switch flight modes

I have changed everything, boards, receivers, transmitters, but I still can’t get the flight modes to change. It’s just locked on flight mode 4. The radio calibration changes with the switch movements from a value ranging from: 969-1522-2076. I’m using the elevon config on plane selection. I have 2 quads running the ardu’s and don’t have any problems at all.

I humbly beseech your learned wisdom.

Please refer to the forum rules and the read me first post and provide the missing information!

Sent from my Ainol Novo 7 Fire using Tapatalk

More information? Okay, here goes:
2 Radios were tried.

  1. Futaba Fasst with r617fs and orange fasst
  2. Frsky Taranis x9d with x8r and 8dr

Both boards tried are ardupilot 2.5 mega, different gps’s but not engaged now.

Just retried on desktop loaded with mp 1.2.33 mav 1.0 with same result

My laptop is using mp 1.2.92 build 1.1.5111.11703

I’ve tried changing the mixing_gain with no result.


without a log it is hard to tell, but my guess is you have your flight mode channel on a different channel than the one set in the FLTMODE_CH parameter. The default for APM:Plane is channel 8, and for copters it is 5. Perhaps you have the mode switch attached to channel 5?
Cheers, Tridge