Unable to start Pixhawk board / unable to establish connection with MP or QGC

Hi guys,

First of all, yes, I’ve read all the related topics I could find that might have solved my problem. None of them did.

So after a “soft” crash with my quadcopter, damaging one of my ESCs, my board won’t start.

Referring to a lot of threads, I assumed it was a bad SD issue. I tried 4
different cards, one of them brand new) and still got the same beeps
and mixer error on the log.

Next step was to reset the board. As recommended on this Ardupilot thread I’ve loaded a plane firmware, then loaded a quadcopter firmware in order to clear all the flight code and parameters.

After that, I keep getting a solid red light on the main LED, solid
green on FMU PWR and solid green on IO PWR. All other lights are off.

When I tried to connect with the Mission Planner (I got the last version on), I kept getting a “No Heartbeat Packet Received” error. As mentioned on this DIYDrones thread, I disconnected the GPS and now I simply can not connect through Mission Planner (Timeout error). When trying to connect to QGC (v3.0.0), I keep getting the “make sure you have an SD Card inserted” error.

This was also with different SD cards.

I’m running out of Ideas guys.

Last Log Files


ERROR [init] PX4IO update failed

ERROR [init] PX4IO not found

ERROR:[init] Could not load mixer: /etc/mixers/quad_x.main.mix


2016_10_18_21_07_16: GPS fix lost

2016_10_18_21_07_18: [lpe] baro init 752 m std 19 cm

2016_10_18_21_07_18: [lpe] z resume

bootlog.txt (1.1 KB)
msgs_2016_10_18_21_07_16.txt (124 Bytes)