Servers by jDrones

Unable to save auto-tuned PIDs after autotune finished / on PXFMini

Hello,
at last I got time to start autotune. Process ran correctly , it took almost 15 minutes. After all copter finished twitching yaw and stayed calm. I switched briefly to stab mode and then to autotune mode back again to retain tuned PIDs. In autotune I landed and then disarmed the copter and switched off the power.
What is my surprise now at home when checking PIDs - they are the same - defaults :disappointed_relieved:
I guess it has something to do with the system - it is running on linux (RBPi2+PXFMini). I have got log from the tuning flight. Can the latest PIDs be extracted somehow from the log file?
If yes, which of the params in log file are relevant for me - when I ran tuning in all axles?
One more question - how correctly do the landing / disarming after autotune to not lose the actual PIDs on system with linux ( like navio or erle brain/ pxf mini)

I dug in log file and found these ATUN records of last steps of particular axles (I think it is in order: roll, pitch, yaw), first record is header for that records, so one can import it e.g. to M$ Excel:

FMT, 25, 41, ATUN, QBBfffffff, TimeUS,Axis,TuneStep,Targ,Min,Max,RP,RD,SP,ddt
ATUN, 395359237, 0, 4, 1424.651, 1497, 1497, 0.07863422, 0.006616293, 4.936475, 55723.71
ATUN, 690076229, 1, 4, 2000, 2102, 2102, 0.06608238, 0.006520705, 3.464626, 38962.51
ATUN, 1055754970, 2, 3, 516.3945, 499, 512, 0.8333341, 1.019534, 3.858188, 6021.073

Can somebody please decode for me which number out of these (Targ,Min,Max,RP,RD,SP,ddt) I should put into which field on MissionPlanner mask “Extended Tuning”?

Well at last today I managed autotune to succesfull end. The PIDs were saved and now I can see them in MP.
After autotune I just left the copter in autotune mode, landed and simply disarmed, then switched off the power.
Guess the problem was with switching to stabilize and back to autotune - perhaps there the tuned PIDS were lost.

Dear friends,
like @lospalos I can not save the PID after tune-up! I did these steps:
1-set channel 7 to go to tune-up mode.
2-set autotune_axe = 1
3-arm in stabilize mode and take off.
4-change to loite mode
5-change to position hold mode
6-set channel 7 to hight
7-after tuning change to RTL mode
8-after landing disarm
9-set channel 7 to low
I had done these steps previously for another pixhawk successfully but I do not know why these steps do not work for this new one! Please kindly visit the *.log file I have shared with this link:
https://drive.google.com/file/d/1AmHxgng4xndH37uyqN4KLfE97SMiS0jY/view?usp=sharing
I do appreciate any comment and/or help.

Tune your copter in alt hold and then land the copter in alt hold mode. You can now disarm and after that set the auto tune switch low. You may reboot the autopilot for just in case and/or change the flight mode to any other and test the new pid settings. Let us know if above things doesn’t work for you.

All you need to do is keep Auto Tune enabled (high) when disarming. That’s it, nothing else to remember.

@dkemxr, But it does not work!!! I did it. Please revisit my explanation.

Review your tune log. It would be in RTL at disarm as you have described it.

When it completes, fly it back, land and disarm.

Sorry, @dkemxr I do not understand where I did wrong, as when I disarm my copter the channel 7 is high. In another word when I disarm my coper still I am in auto-tune mode. Is it wrong? Again, I did not use the Auto-Tune as one of the flight modes, I used channel 7 to go to auto-tune mode.

I think Auto Tune was overridden by your switch to RTL. If you want to use RTL after Autotune then after it lands and before you disarm toggle the switch you have Autotune on Low then High and then disarm.

Thank you @dkemxr I will try it.

Thank you @Mustafa_Gokce, I’ll try it.

1 Like

Today I have another test with position hold mode. I did not change the flight mode after tuning and landed in position hold mode. Then I could save the new PIDs. As @dkemxr mentioned changing to the RTL mode maybe override the Auto-Tune. Anyway, thank you all.

Servers by jDrones