Unable to re-establish connection to aircraft

Problem: after temporarily disconnecting the ethernet connection between the GCS and the groundside radio, we are unable to re-establish link between mission planner software on the GCS and the UAV.

Test Scenario Setup:

  • 2 x Silvus radios (1 x groundside, with our tracker antenna - and 1 x airside in the UAV)
  • Silvus radios connected - no issues
  • Ethernet connection from ground control station to groundside Silvus radio
  • Mission planner connects to the aircraft - no issues

Test 1: close the mission planner software. Wait for 15-30 seconds and then re-launch mission planner.
Outcome: After re-launching mission planner, we are able to establish a connection to the aircraft. Outcome works, as expected.

Test 2: Following on from Test 1, we then disconnect the ethernet connection between the ground control station computer and the groundside Silvus radio (to simulate this cable failing). Wait 15-30 seconds then reconnect the ethernet cable and attempt to establish link to the aircraft via mission planner
Outcome: We are unable to re-establish the connection.

We have also tried closing and reopening the mission planner application, but it won’t reconnect to the UAV. The only way we can get the connection back is by power cycling (turn OFF, turn ON) the UAV. Obviously this is not a workable solution if the UAV is in the air when the ethernet connection is temporarily lost.

Does anyone have ideas on what could be the cause of this? And how we can re-establish a connection from Mission Planner? Just to be clear, once we reconnect the ethernet lead, we are able to ping the IP address of the groundside radio, and we can also see that the Silvus radios (groundside and airside have a good link) but for some reason, the mission planner software is unable to communicate with the UAV.

Let me know if there are any other details that are not clear from the above.

try using udp protocol

We will test this and see what happens on the bench, but I believe that all error checking and the ability to re-transmit lost packets is not available if using UDP, so not sure this would be viable moving forward.

In MAVLink, configuration sub-protocols are point-to-point with retransmission, unlike topics. MAVLink also has its own error checking. So it is safe to use MAVLink over UDP.

You could try pinging both Silvus radios from the GCS computer to help isolate whether it is a radio-related problem or not.

If you suspect it is a radio problem and need help from Silvus, you can email support@silvustechnologies.com for troubleshooting assistance.

Good luck,
Jimi Henderson
VP Sales, Silvus

For our use case, what are the pros/cons of UDP v UDPCI ?

Thanks all for the info so far, we will resume the testing this week and I will update this thread with the results.

Just for interest, can you say what Silvus radios you’re using?

We are still having connection issues - unable to connect to the UAV from mission planner

We are using TCP, baud 57,600 - and we get an connection error message stating that

“No mavlink heartbeat packets where read from this port - verify baud rate and setup”

Have tried UDP, this does not connect either

Can confirm that we can ping the UAV from the GCS, and connect to the silvus airside IP address / interface (via the silvus radio network)

We have also tried connecting directly from the GCS to the UAV via ethernet (taking the Silvus network out of play) and we get the same problem, no connection, “No HeartBeat Packets Received”

However, if we connect directly to the UAV by USB cable and then connect mission planner via a COM port instead of TCP, then this works

(Silvus radios are SC4200E)

Anyone have an idea of what’s causing the issue?

have a look at the following documentation Technical Library For Mobile Industrial Mesh Radios | Doodle Labs