Unable to perform "ROI" or "Point camera here"


As in the object, my quad with a pixhawk running arducopter 3.4.3 stable, can’t execute “ROI” or the “Point camera here”.

The quad perform Loiter, alt-hold and auto mission very very well, and even guided and circle mode works with no problem at all…

In auto mode I have inserted a ROI in a simple mission and the quad completely ignore it: when it arrive at the ROI it dosen’t yaw (i have a tarot t2d 2 axis gimbal) to point in the ROI direction and the gimbal don’t point down at the desired ROI altitude.

I have tested the “point camera here” too: the quad doesn’t yaw in the desired direction, and the camera rotate 90 degrees up and remains blocked in that position unitl i land and disconnect the battery… Mission planner give an error at this point: “The Command failed to execute”.

Below a link to my google drive folder with some ***.bin files of my test, the mission.txt file of the auto mission, the full parameter list of my pixhawk (parameter.param) and the screen shot of the mission planner’s error.

The problem is solved!!

I’d like to share with the comunity the solution: it was a my error with the configuration parameters.

My gimbal configuration was like the procedure described in the wiki, so i have used my radio channel 6 ti control the gimbal tilt connected to the aux1 (rc9) on the pixhawk.

And then, i have used my radio channel 8 to control the gimbal operation mode with another wire connected on the aux2 (rc10) of the pixhawk, but my error was to configure this part, in the gimbal setup page of the mission planner, in the “pan” section.
From the radio the gimbal work as expected, but in auto mode, the drone won’t yaw itself in the ROI direction.

The solution was to configure properly the gimbal operation mode like described in the mike_kelly guide, all credits goes to him.

So i have moved the wire connected to the tarot “operation mode switch”, from aux2 (rc10) of the pixhawk, to the motor output8 and then i have configured the rc8 like below:

RC8_FUNCTION,1 → passthrough of rc8 of my radio
RC8_REV,-1 → inverted

With this configuration my quad execute correctly all the ROI waypoints in auto mission, as well as commands like “point camera here” from tower and after a little bit of adjustment of the pwm values on my taranis, even the control of the gimbal from the radio is perfect.

Great that you figured it out.
So I guess, where things went wrong in your setup is that the yaw was configured on the gimbal setup page in the MP. This made ardupilot think that the gimbal supported yaw so the vehicle itself would not yaw when the ROI command was executed.
It’s not clear to me what we could add to the wiki to clarify this. Can you think of anything?

You’re right!!
My mistake was the configuration of the aux2 (rc10) of the pixhawk.

I have followed the official wiki about setting up a tarot t2d gimbal for the first part of the configuration (set up the tilt control of the gimbal):
But for the configuration of the gimbal default mode with a spare channel on my radio (in passthrough), i found very very clear this little guide posted by mike_kelly on rcgroups:

Hello I have the same problem I have a tarot 2d to use it with the station works perfect but when you pass it to auto mode the gimbal is blocked and I can not move it, I have it connected with the white and regro cable that brings the gimbal to the pix aux 1 but you say you have to connect it to another place or add another servo could you upload a photo of how you have it