Unable to launch Gazebo world after installing ArduPilot Plugin

Hi! This is my first ever post on the forum. I need help and was hoping I would get some here. I am following: https://ardupilot.org/dev/docs/using-gazebo-simulator-with-sitl.html#using-gazebo-simulator-with-sitl to help my simulations get up and running. Upon executing the command:

gazebo --verbose worlds/iris_arducopter_runway.world

I am thrown an error message that says:

gazebo: symbol lookup error: /usr/lib/x86_64-linux-gnu/libgazebo_common.so.9: undefined symbol: _ZN8ignition10fuel_tools12ClientConfig12SetUserAgentERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE

It might be worth noting that I use Zsh on Ubuntu 18.04

I have no clue what this means and what needs to be done to correct it. Any help would be highly appreciated. Thanks!


After a quick Google search, I’ve found this :

Can you try to perform sudo apt upgrade libignition-math2 and then run again gazebo only with gazebo or gazebo9 command ?

Hi! Sorry for the late response, I was a little sick. Upon your recommendation, I did sudo apt upgrade libignition-math2 as well as sudo apt update and sudo apt upgrade. The result is that the error messages are gone. When I run gazebo --verbose worlds/iris_arducopter_runway.world, things seem start moving. However, the actual simulation never

seems to start up. I am left with a strange transparent box in the middle of my screen, along with all the other ardupilot terminal messages. I’ve uploaded the same for your reference. This same strange box is also displayed when I run gazebo on my terminal. Also, gazebo9 is shown as an invalid command. Thanks

@raghavthakar Did you find a fix for the transparent box getting stuck issue?

Should have posted this here earlier, but just give it some time. Like a lot of time (5-10 minutes even). Gazebo should start eventually.