Unable to Initiate compass calibration

3DR APM 2.6 with external 3DR Compass
Build 3.1.2 Heli

I was in middle of compass calibration when my laptop went into sleep mode ! .
Now when I go to compass calibration it gives the following error. ( screen shots attached )

To resolve issue I have tried all these below but to no avail the error is exactly the same every time :

  • I have used ‘erase’ command from CLI .
  • I have tried uploading new firmware, it goes through but that does not help the issue ( Tried both old and new firmware )
  • I have used ‘reset’ command but that does not go through as expected , after I press ‘Y’ it gives not message of reset , just says 'Reboot APM ’ and hangs

It will be nice to have some idea , has the hardware gone bad ?
Attached log file .

Not much help to you, but I’m getting the same error on both my apm 1 and my apm 2.6. I had previously done a calibration on the apm 1 and although it won’t calibrate now on live calibration, it does pass the arming checks and seems to fly fine. The apm 2.6 is new and it doesn’t pass the arming check and so have asked on the 3.1 sub forum about that issue.

I updated my mission planner to 1.3.7 and it then calibrated without any problem. I tried the planner 2.0 and that also didn’t work.

Thank you jeffridj ,upgrading MP to 1.3.7 resolved the issue