Unable to get my GPS lock a satellite

Hello there;

I have a Pixhawk[1] and it was working fine but after flashing into the latest Ardupilot firmware version (4.1.2) the GPS stop getting locked to any satellite. The copter has been flying perfectly the only problem I have is the GPS, I’m no longer able to set to hold position or RTL. I was using 4.1.1 if I’m not wrong and after the flashing things have changed on the flight mode menu, now they are many more options flight modes, so if it’s possible that those changes have affected my GPS module?, is my GPS no longer compatible with the newest version of the firmware?, by downgrading my firmware I’ll be able to have this fixed?.

Let me know your thoughts if there is anything else I can do o try to fix this problem I will really appreciate all your help.

[1] https://www.amazon.com/dp/B07QH5QXLL?psc=1&ref=ppx_yo2_dt_b_product_details

No an update from 4.1.1 to 4.1.2 will not make the GPS receiver stop working.
But interference, or no reception due to sky blockage will.

Try again in an open space

1 Like

Hello @amilcarlucas ,

Thanks for replying. Well, I have been flying it as I said expecting the GPS to get back and running but nothing has changed. I always fly it in an open space at a park nearby me. I fly it for a few minutes and then land it to check if I get any green light but it keeps flashing blue. In fact, I have an external GPS i2c connected to the drone both shows active and available on the Mission Planner but they are not catching any satellites, I don’t know how many times I have practiced the calibration, I have tried indoor, outdoor, I have changed options, configurations deactivating one other GPS but the result is the same. In the field, if switch to RTL or Hold position it fails to change the flight mode.

Do you know if there is any way for me to collect the logs or something else that can tell me what can be happening? I’m looking to troubleshoot because is a mystery,

Thanks again for all your support.

RTL and position hold require good GPS reception and a so called “GPS FIX”. So until they blink green it will not work.

  1. What make and model are your GPS receivers?
  2. How are they connected?
  3. Are you sure the cables are correctly connected and secure?
  4. Did you recently changed ArduCopter parameters? Or loaded a parameter file?

Hello @amilcarlucas

Thanks for replying back I really appreciate your time. So answering your questions:

  1. What make and model are your GPS receivers?

Please refer to the attached image, this shows on Mission Planner the details of both devices.

  1. How are they connected?

It basically has the internal Pixhawk GPS and an external GPS that is connected via I2C at the top of the Pixhawk, there is no way to connect this last one wrong because there is only one way to connect it and if so it will not be showing in the Mission planner menu as it shows in the image attached.

  1. Are you sure the cables are correctly connected and secure?

I want to believe they are at least the external one, but again, I have try disconnecting the external GPS and flying with only the internal GPS but I still get the same result.

  1. Did you recently changed ArduCopter parameters? Or loaded a parameter file?

No, no really the only thing I have done since it stop working was upgrading the firmware that’s what I believe may be the problem.


Sounds to me like you are confusing compass with GPS receiver.

  1. There are external and internal compasses. But there are only external GPS receivers.
  2. Compasses are connected via I2C. GPS receivers are connected via UART also known as serial.
  3. I asked you information about the GPS, you send me information about compasses.
  4. Most GPS receiver modules do include both a GPS receiver and a compass, and are therefore connected via both UART and I2C.

If you do not have GPS reception, your problem is the GPS receiver unit, not the compass.

The photos you sent from the GPS receiver are really bad quality. The text on top of the unit is not readable.

1 Like

Hello @amilcarlucas,

Thanks again. Yes, you totally right!, I’m mixing up everything I’m sorry I’m just a newbie :stuck_out_tongue: So getting my own conclusion based on what you are saying definitely the GPS external module is broken or not working properly, it’s completely possible because I give it a hard crash and it was all in pizes, I have double-checked the connections port and they are all correct. The easy way for me to prove my theory is by buying another GPS external module. Sorry for the pictures attached you will find a better one I hope this time you can read it properly. I really appreciate all your time helping, I’ll try to purchase the new GPS module and keep you posted regarding the progress. Thanks again and Happy holidays.

Ps: If is there any GPS external module that you can recommend to me I will really appreciate it.

Hello there,

Problem solve!, it was my GPS external module I connect the new one and now everything is working. Thank you for all your help.


1 Like