Unable to get a good tune on 16 inch quad

I am unable to get a good tune on my quad, leading to a unstable flight.

I have tried:

  • Followed the initial tuning guide
  • Autotune
  • Manual Tune
  • Telemetry notch filter
  • Dynamic notch filter

I am able to tune the quad both manually and with the autotune, both resulting in comparable PID values, but the result is not good. The UAV feels twitchy, both in AltHold and Loiter, and the logs show that the roll and pitch values fluctuate around the desired position.

Tmotor MN4006
Tmotor 16 inch folding CF prop
Airvolute DroneCore with Cube Orange plus and a FOC motor controller
TOW: 3.4 kg

Flight log can be found here:

Yes, the drone crashes due to instability at the end of the flight log.

Certainly agree with that, it looks poor. The Rate filters and Gyro filter are low for a 16" on 6S.
What do you mean by “telemetry notch filter”. You don’t have a Dshot protocol configured nor Bdshot firmware running so not sure what you mean by this. I see you do have ESC RPM in the log anyway so that should be driving the notch filter. Well, only on One output so that’s not going to work.

The current Notch filter configuration as Dynamic FFT isn’t doing anything as you don’t have FFT enabled. If you want someone to review the Notch Filter requirements set these:
A MOT_SPIN_MIN value of 30% is very high. Did you follow this procedure? Setting Motor Ranges

A note about those motors (no idea what the ESC is): There have been posts claiming desync with those motors more than any I think.

I have telemetry feedback from each ESC, you can find it in the log. This FC, an integrated unit with an FOC controller, does not use the Dshot protocol. Shouldn’t that work with the telemetry notch filter?

The MOT_SPIN_MIN value is according to the manufacturer’s recommendation, as they had trouble tuning the FOC controller to this motor. I believe that comes from the same desync issue you mentioned.

Yes. I see there is RPM for all motors my mistake. Configure the notch for ESC Telemetry.

Perhaps the trouble remains.

But to be honest I’m usually skeptical when someone makes a dysync claim because it’s usually hard to prove. After all else is ruled out…

Recommendations for what? I don’t see much if any support from T-Motor for Ardupilot. The threads where they do contribute posts usually end up unanswered. Did they also suggest that Expo value?

Since the UAV has a problem following the desired position even at hover with zero attitude command, I don’t believe this to be a desync problem.

Reccomandations from Airvolute who makes the ESC, not from Tmotor. There was some trouble getting this motor to work with the ESC, and I got the high MOT_SPIN_MIN value from them. They also provided the expo value.

Cool, an Ardupilot Partner.

Yes, but still no luck in tuning this setup.

I have tried with different expo values and filter values.

Here is the latest setup, with a throttle filter.

I am running out of parameters to adjust. Any ideas?

Filter looks good. You could tweak it a bit with the center frequency at 68Hz, BW at 34Hz and a ratio of .75 or leave it as is.
I think you should try some more aggressive PID’s. Set the Rate D-terms to .006 and the P&I’s back to default and see if there is improvement. I would use in-flight tuning at this point. Time consuming but Auto Tune isn’t getting it done.

I applied the filter settings and tried to do some manual tuning of the roll axis.

I am able to increase the D value to 0,007 and P/I to 0.13, but it gives a lot of overshoot. It doesn’t look like I can get a good tune by just changing the rate values, I believe there is something else wrong.

Yea, looks terrible. Your Rate filters are still too low for 16" on 6S.