Unable to gain access to bootloader - APM 2.0.25 Firmware Install

Hi fellow pilots,

I used to be able to connect my CX-20 to APM Planner 2 and everything worked well. Now when i try to connect there is no telemetry, so i’m trying to do an initial firmware setup again but it keeps coming up with 'Unable to gain access to bootloader’
I am running OX 10.13 High Sierra, i have installed the USB drivers. I also tried to do this via parallels on the mac with Windows10 and it come up with the same problem.

Any help would be greatly appreciated. Cheers Chris

I’ve got three CX-20 flight controllers in the box with the same symptom.They get irreversibly corrupted by the dodgy USB port on the bottom of the copter and there is no way of accessing the DFU mode to repair the bootloader.Or,I’ve never found a way to access the DFU on one of these boards.You can do it easily on a full APM 2.5/2.6 but not the cut down matchbox version fitted to the CX-20.The pins are not there and nor is the documentation.

All of my Novas (Hobbyking CX-20) now have Pixhawks and they fly a damned sight better for it.The original FC is a fun place to start but they don’t last long in my experience.

The only thing you can try is a handfull of USB leads in the hope that it didn’t yet corrupt the bootloader and it’s just the USB port.As a last resort remove the shell and hook the USB directly to the FC.