Unable to downgrade


we’ve multible copters with identical configurations all based on ArduCopter 3.5.7.
Now I have to flash a new Pixhawk 2.1 to 3.5.7.
I’m running Mission Planner 1.3.68. When ever I click on “Pick previous firmware”, choose 3.5.7 and click on to the quadcopter icon, a new window will appear asking for type, version type, platform and so on.
However, the drop down version only lists 3.6.9.

Reflashing of 3.6.9 works fine, but I need 3.5.7.

Do I overlook anything?

Best regards
Daniel Kröhl

Ok, it’s done.
After installing the beta version of today (1.3.68 build 1.3.7124.7270), I was able to install version 3.5.7.

In the attempt to configure the 3.6.9 before, it was not possible for me to get the telemetry via Crossfire up and running.
When flashing 3.5.7, the settings were adopted and it worked directly.

Best regards
Daniel Kröhl