Unable to do radio configuration turnigy 9x

Hi everyone,
I uploaded the latest megapirate firmware on this board
hobbyking.com/hobbyking/stor … h=multiwii

i calibrated the accelerometers and the compass, no problem with that.
But then when I wanted to calibrate the radio (turnigy 9x) the sticks remained blanks even though it is connected. (the transmitter is normally fine as the receiver, it worked with multiwii 2.2).
I checked also in the file RCinputs and i tried PL1 but nothing changed.

When i enter the terminal, it says “failed to create throttle curve” but i think it is because i did not calibrate the radio.

Anyone to help me ?

You do realize that this support forum is for APM:Copter software and not MultiWII or Megapirate (which I actually even never heard of)?

I’m not sure what you mean with “sticks remained blanks” but it sounds like you have a connection problem between your board and your receiver. It’s really hard to understand your point.
I realize that English is not everyone’s native language - I myself am German and live in Finland :slight_smile:. But you should try to spend an effort on writing in a way that your problem becomes really clear. If people don’t understand what you write, it’s hard to help you. Maybe you could ask a friend to translate for you?

But again - I suspect, you are probably in the wrong forum for your board and software.

You are right, this post should be over at RCGroups where the MegaPirates firmware is supported. Also, as you have pointed out, the member’s hardware is not APM.
Should this post be deleted or let the member go to RCGroups as I have indicated above?
TCIII Developer

The hardware is irrelevant for the software support forums. If somebody runs e.g. Copter on an RCT APM 2.5.2 we still support software-related issues, config, tuning, etc. We just don’t support hardware problems with those boards.

I don’t think, the post should be deleted - it still points potential other searchers to the right direction.
As I said, I have never even heard of the Megapirate firmware, so if it’s officially supported at RCG, that’s indeed where the user should go. Can you post a corresponding link to the right thread at RCG?