Unable to connect using UDP Port

Hi,
I am using Arducopter 2.8 with 3.2.1 firmware. I got a Wi-Fi telemetry module running MAVESP8266 Version: 1.2.3 I am able to connect to the Wi-Fi module and access configuration page.
When I am trying to connect using Mission Planner, I get the following error: Only one usage of each socket address is normally permitted The local port I use is 14550
Also the documentation available is for Pixhawk, if someone can redirect to some documentation for Arducopter 3.2

4

ArduPilot dropped supporting this board and firmware version many years ago. Get a recent board.

I understand this board is obsolete and no firmware update after 3.2.1. But can you confirm if Wi-Fi telemetry is supported in 3.2.1 or not. Thanks

It may work but I think you need to downgrade the Mission Planner.

Missionplanner listens on port 14550 for incoming UDP telemetry by default. So the port is already open and in use. Using the same port for a manually initiated telemetry connection will lead to this “already in use” error. If your setup is sending UDP telemetry on port 14550, Missionplanner should pick up the stream by itself. If it does not, there is a problem elsewhere.

Thanks, that makes sense. But as per the documentation

Mission planner wont start receiving data unless its connected using UDP.
I checked the SERIAL1_BAUD and its set to 57 which is correct rate for APM

Have you checked the wiki
https://ardupilot.org/copter/docs/common-esp8266-telemetry.html

And make sure you dont have other connections using UDP 14550 running

I followed the wiki, it is for pixhawk does not have documentation for APM.

Please note APM is outdated and no longer supported… since 6 years.
It is really unfortunate that online store keep selling these,its like selling Iphone 4 or BlackBerry

This documentation is from 2016. Missionplanner does listen on port 14550.
If you try to open it a second time by trying to open a UDP connection, you will get the error you mentioned.
Change your ESPs settings to 14551 for example and you will not get that error.

I changed the port on ESP and now I don’t get the error but it says Mavlink Connecting and that stays on forever.

And that indicates there is an error elsewhere. Check the baudrates, connections (tx>rx, rx>tx), the ESP configuration (target ip) , etc.

[Solved] Its resolved now. After fiddling with the software part thought let me take apart the module itself.
Found 2 resistors were touching each other, I just took then apart and it worked.

@count74 You were right port 14550 is always listening and it connected right away, I did not even have to click connect.

Thanks all for your help.