Unable to connect Matek F405 Wing to Mission Planner

I suddenly cannot connect my Matek F405 boards to Mission Planner by USB. When I plug in the USB my Win 10 computer automatically sets up a Com 5 Port called Ardupilot with Port Settings showing 9600. However when I try to run Mission Planner I cannot connect. I tried changing the baud rate of the port and the settings in Mission Planner but nothing seems to work. Can anyone suggest things to try? The connection used to work fine so not sure what changed.


Try updating your mission planner and select the “Auto” settings.And then wait.Some times it work after waiting.

Usb connectors on some mateks are fragile.