Unable to connect APM 2.8 to Mission Planner via bluetooth

Hello there, I am in the process of making my first Quadcopter but I am unable to connect my APM flight controller to mission planner using MAVlink. I am using a HC-06 bluetooth module and have set the baud rate to 57600. MP is running on Windows 7 64-bit. Selecting the correct COM port and baud rate in MP software, it tries to connect and it seems they have found each other (red led goes solid on the HC-06 and in top right corner of MP it shows connected) but then the MAVlink dialog box shows “trying to connect - timeout it 28s, 27s, 26s” and then just shows “connection failed”. On clicking on details it shows “timeout” exception. Can you help me out please? I am almost about to give up on this project as it has been a month now and I cannot find any solution. I have searched extensively on the net and this site but non of them helped. I am a 9th grader and very passionate about robotics and automobiles. I would be very grateful to your help. Thank you.


OS - Windows 7 64-bit; Mission Planner 1.3.48



Airframe type


Hardware type

APM 2.8

**I have tried Mission Planner version 1.3.35 in which my joystick setup works(I want to fly with a joystick and joystick was not working with MP 1.3.48) fine but even there I get mavlink timeout while connecting via BT.

Here is a snapshot of the error -

Have you tried swapping your RX and TX wires? It shouldn’t hurt anything if they’re wrong. Did you configure the HC-06 with a PC before connecting it, or are you relying on the APM to configure it?

Yes, I configured the HC-06 module with my PC. I did it in the same way as explained in this post - http://ardupilot.org/copter/docs/common-mission-planner-bluetooth-connectivity.html

I think that the RX and TX wires are all right, I will try swapping them and let you know.

Thank you.

Also, it connects all right using APM Planner 2 at 57600 baud. So I don’t think that there’s any problem with HC-06’s configurations.