Unable to connect after upgrade

I upgraded yesterday from version 3.2.3 to 3.3.0
Upgrade worked perfect but afterwards I am not able to connect anymore.
It looks like the APM is not booting anymore in a correct way.
It is not only a question of connecting also the system ist not working.

I reinstalled version 3.2.3. and it worked perfect with this version.
I tried to upgrade again - same issue as before.

I do have the APM 2.6 with a disconnected onboard compass.
Any idea what to do?


I found the reason for the issue.

As I mentioned I disabled the onBord compass on my apm 2.6 by cutting the bridge.
Reason for this was that I was not able to calibrate the compass and always got an error message.
Nevertheless the apm was running without attaching an external compass.

This changed with the version 3.3.0

I tried to connect to apm by the terminal and got the message “no compass”.
As soon as I attached the external gps with compass I was able to connect to the apm in the normal way and the system is running now with version 3.3.0

Therefore the issue is solved. With version 3.3.0 the apm is not able to work without compass.