Servers by jDrones

Unable to compile Mission Planner

Hello everyone,

I want to compile Mission Planner solution without making any changes to the code.
I followed the instructions found in below link:
Building Mission Planner with Visual Studio — Dev documentation (ardupilot.org)

I am using Microsoft Visual Studio Community 2019 Version 16.9.2.

I checkout the MissionPlanner1.3.70 tags.

When I compile, I got the following errors:

Can someone help me?

Thanks in advance.

Now I managed to compile with no errors. However, when I start running the program, it throws exceptions:
"System.IO.FileLoadException: Could not load file or assembly ‘SkiaSharp.Views.Desktop, Version=1.60.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756’ or one of its dependencies. The located assembly’s manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040) "

I have placed binding redirect element in app.config file. However, it still doesn’t work for the ‘SkiaSharp.Views.Desktop’.

Has someone encountered this issue?

Thanks.

Why do you use 1.3.70 ? That is quite old, I would rather go for the Master branch or the tag Beta. (The skia sharp issue was fixed in them)

Thanks for the reply. I tried using the lastest one, but it is too slow to build and run and have some errors too.

Now I tried again 1.3.73. I got these errors although .dlls files are in the folders.

did you image after cloning ?

Yes I did. Now I clean the solution and build rebuild then those errors are gone now.

So now successfully built and run. 1.3.73 tags. However I have one problem. I have designer error in my main designer as below:

This was fixed in the beta afaik.
Still recommend to move to tag beta, there are tons of fixes.

Oh I see… I shall try again the master version then. Thank you.

Hi, now I’m running MP master. The designer is fixed. and the rest looks good too. but only this error for firewareselection.xaml file.


Do you have any idea for this? thanks.

Are you try to build a xamarin version (Android ?)

For my project, I do not need that. I have commented out this [XamlCompilation(XamlCompilationOptions.Compile)] and I do not get any errors. Thanks.

When I run beta version, I got this error.

Did you updated your build machine to the latest Win10 release and fixes ?


This is my machine’s current status.

Servers by jDrones