Servers by jDrones

Unable to change pid settings

(Joshua Springer) #1

Hi guys, I have been working on an autonomous airboat and am unable to change the PID settings, so the boat is all over the place. I have tried to change the steering and throttle PID coefficients in APM Planner and Mission Planner. The coefficients themselves are greyed out in Mission Planner and simply won’t change via APM Planner. The period and damping parameters will change in APM Planner and are not greyed out in Mission Planner. I have tried to change them using a udp connection over wifi and using a serial connection with one of the 3dr radios. Changing most parameters, and changing settings in general, works easily all of these platforms/interfaces, but PID coefficients are always either greyed out or won’t change. My main board is a navio2 which I have used in the past on a rover project and it worked fine. However I also just tried a pixhawk v2 that I had lying around (which has also been used previously on another boat project with no problems) and the PID coefficients won’t change on it either. Even more confusing, I have uploaded the copter firmware to both of these boards and the PID coefficients are changeable.

What am I doing wrong? Has something changed in the newer version of ardurover?

(Joshua Springer) #2

By the way I have tried using the 3.1.1 firmware from Mission Planner which solves this problem, and I have also manually uploaded the 3.1.1 firmware after compiling it manually on ubuntu and it works. Time to rewrite a ton of code for this version of the firmware…

(gmorph) #3

Not sure what you were trying to change - which parameters specifically?

Thanks, Grant.