Unable to calibrate ECS or run engines at all for a differential setup

I am creating a boat that is propelled by differential thrust. Im using the Mateksys H743 V3 with the external M10Q GPS module. A SiK telemetry radio from Holybro is also connected and works fine. I’m using the flysky FS-I6 transmitter and FS-IA6B reciever. There is signal through and I can see the pwm numbers change in missionplanner.

The issue is im unable to make the motors turn. Im using two Quicrun 1060 brushed ECS and two MT550 motors. I’ve been reading the ecs calibration documentation and watching alot of YouTube videos, but I feel like im missing something fundamental to make it work.


  • On Mateksys website it says on the wiring diagram to connect to Serial 1 and 2. But on the ardupilot mapping tab its serial 4 and 5 that connects to channel 2 and 3, which I understand is the throttle stick. Sooo which is input is correct? http://www.mateksys.com/?portfolio=h743-wing-v2#tab-id-6

  • The ecs are blinking red which says in the manual means the inputs are not centered

  • In the radio calibration tab its displaying up to radio 16, so up to 16 channels? As I understand it my transmitter only has 6 channels, is it an issue it shows up to 16?.

  • Throttle inputs in servo output tab in missionplanner shows the trim setting it seems?

Is there anyone who has any ideas, where I’ve gone wrong? On all the youtube videos it seems very plug and play. Im not able to calibrate at all. Let me know if more information is required I’ll leave some photos of the setup here

Kind regards

Hi @PhillipB,

In case it’s not clear, it’s important to keep in mind that RC inputs and PWM outputs are separate things.

MP’s “Radio Calibration” page shows the RC inputs which are coming from the RC receiver (normally a 3-pin cable) into the autopilot (usually into a 3-pin port called “RCIN” or similar). I wouldn’t worry if you’re seeing 16 green bars when the RC transmitter/receiver is only 6 channels. If the green bars for throttle and roll are moving then it should work OK.

MP’s “Servo Output” page shows the PWM values being output on the autopilot’s servo output rail. So there should be one for each ESC. Looks like you’ve got it setup to output on output channels 2 and 3 so one ESC should be connected to the autopilot output2 and the other to output3.

If you put the vehicle in Manual mode and arm it then you should see the Servo Outputs change as you provide throttle and roll input. You can also more directly test each motor by disarming the vehicle and then using MP’s Motor Test screen.

The most likely issue I can imagine is that the ESCs are not setup to spin the motors both forwards and backwards. For ESCs that only spin forwards, normally the min is 1000 or 1100, max is 1900 or 2000 and trim should be the same as min. If the ESCs can spin forwards and backwards then the trim is normally 1500 (halfway between min and max).

Anyway, not sure if I’ve answered your question but hopefully this helps in some way.

Thank you for your answer.

I armed it and but it into manual mode and it was lovely to see that the outputs were correct and true to what I hoped for. (Full throttle left turn in the example.)
I believe I’ve set up the trim correctly. Trim is 1500 in the servo output tab. 1100 min and 1900 max

The motortest does not yield anything significant. I get an “Command was denied by the autopilot” error. From another forum post its suggested to:


It has been attempted without succes.

I’ve tested the motors separetely from the FCS and ECS and they spin. I am unsure how I can perform an isolated test on the ECS. They’re blinking so surely they work. Any suggestions on this?

On the mateksys wiring diagram its showcased that the “RCIN” 3-pin port has the red wire cut. I’ve tried to run it without the red wire connected and with it connected. As I understand it, its a wire for voltage regulation which is not required here?
Photo of the connection:

Thanks for your time and effort

Kind regards

Hi @PhillipB,

The “Command was denied by the autopilot” is probably happening because one of the arming check is failing. If you look back on the Data screen’s Messages tab (bottom left) you’ll likely see what the failure is. The most likely cause is some calibration has been skipped.

If you can make the ESCs/motors spins by directly connecting them to an RC receiver or servo tester then it should definitely be possible to get them spinning with AP.

Thank you for your advice. It has been solved. I initially tested the RC reciever and motors on a DC power supply, and not the actual battery used with the flight controller. It turned out that the lipo battery I was using was not compatible with the motors because it was 4 cell.

I hooked up an old Lead Acid 12V battery I had laying around and it working flawlessly after calibrating all the instruments. Do you reckon there is any issues with using a lead-acid battery?

Anyways, Thanks for the help… For now;)