Unable to calibrate compasses in MP but QGC worked

I have a class of students building quads using AC4.2.3. Today a bunch of them went to calibrate their compasses and mission planner wouldn’t do anything. Just click the button and nothing moved.

Versions of MP would have ranged from stable to latest beta, no difference.

The part that has me confused is we tried QGC and it worked fine.

FC matek F405WSE
MQ8-5883 gps/compass.
AC 4.2.3

Any ideas?

Strange. I’ve used a couple of the same Matek modules in the recent past without issue, always using MP latest beta for calibration. In fact, I find them to be among the easiest to use! Sorry I can’t be of more assistance…

Agreed. I’ve done a number of builds with this hardware and never had a problem like that. When it happened to the first student it was easy to write off as an anomaly, but when the third and fourth told me they were hitting the same issue I got to wondering. It was only a long shot I even tried QGC, but just glad it worked.

1 Like

Just a guess, but perhaps linked to the OS?
Are you blokes using Windows 10 or 11?
…just a thought.

1 Like

Probably good to specify!

I always use Windows 11 for MP.

Good point. The students use their own computers but if I had to guess I’d say most are windows 11. I’ll check that next week when I see them again.

Just asked and everyone was using windows 11.