Unable to Calibrate Accelerometer

Hello all, I am very new to the whole multi rotor world and it has definitely been a challenge so far. I am running the newest APM 2.0.8 on my mac (APM 2.0.7 had the same issue). Everything seems to work fine except for the accelerometer calibration. I can do the radio and compass calibration and see on the flight data page the virtualization of my UAV. However when I go the calibrate accelerometer tab and click the button nothing happens. No messages or anything. It looks like the button depresses, but nothing happens. When I do the other calibrations, messages pop up and say what to do.

Am I doing something wrong or is it some software issue?

Can I use the auto trim (copter.ardupilot.com/wiki/autotrim/) to get the same results?

Any help would be much appreciated.

Hi Georgiadesk. I have the same issue and I have found two options for getting the calibration. The first option is to carry out the procedure by clicking the calibration button and then continuing the procedure… level, left side, right side, nose, tail and then upside-down, hitting any key after each position. If you then go to the “flight data” page and click on the “messages” tab you will see the process displayed and the success or failure of the calibration. I have had mixed success doing it this way.

The best option I have found is to go into terminal mode, click on connect using the USB cable. Then click in the terminal window and type “setup” hit enter and then type in “accel” hit enter and follow the instructions.

Works every time for me. If you haven’t used the CLI (command line interface) before, you can view a list of available options by typing in “help” and “exit” to go to the top menu. There’s lots of good stuff in there!

Thanks so much VSOPilot! The terminal version worked with a little effort. After I typed setup I typed accel and nothing happened. I was running megapirate 2.7 and thought that might be the problem and I should update to the latest mpng. After installing the latest megapirate 3.0.1_r4, the terminal accelerometer calibration worked just like you said.

Other notes to anyone else having similar issues. To get the newest mpng to compile without errors in arduino I had to make a clean directory where I unzipped the app file. Right click on the app to show package contents and replace the libraries folder with the one from the latest mpng. What I also forgot to do was to copy the pde.jar file in addition to libraries. Show package contents, then Contents>Resources,>Java. This is where the libraries fold and the pde.jar file get copied to, replacing the old files.

The other thing to be aware of is the ppm and rc channel inpot order is no longer in the config page in Arduino. You need to open a file from libraries to change. megapirateng.com/how-to-conf … -firmware/

So, the issue of calibrating the accelerometers is solved. Thanks VSOPilot. But there still seems to be a small bug in the software that needs to be addressed. Other than that, everything else seems to work great. Thanks dev team!

What version of the APM software are you using?

I just installed 2.0.8 a few days ago, and before that, it was 2.0.7. Both had the same issue where pressing the calibrate accelerometer button did nothing.

I don’t mean APM planner 2.0 version, but the autopilot version.

The quad I have is the Locust ARF from fpvcentral.net/2013/12/locust-ar … it-review/.

So, the flight controller is a Crius AIO Pro v1.1.
Just last night I updated to Ardupilot mpng 3.0.1 R4 using this code: github.com/MegaPirateNG/ardupilot-mpng

Tonight I was running through all of the calibrations again and thought I should try to calibrate the accelerometer without using the terminal. It worked! After that happened, I thought about it and realized that after I upgraded megapirate to 3.0.1 r4, I never tried to calibrate the regular way, only through the terminal. It was an error on my end, no software bug. Thanks for all your help, and glad I was able to learn a little more and figure out how to use the terminal.

had same issue
tried to follow your fix
nothing!!! no joy
so I had seen another fix the suggested typing “level”- return
that worked -it just did it - no instructions to follow - problem solved
all the best