Unable to calibrate accel on 3.3 and rate P very large


On 3.3beta calibration of the accel always fails but it completes absolutely fine first time on the current stable version. I tried reversing the commit that increased the accel range to 16g but ahrs then failed.

Also, my rate P at 0.15 allows the hex to fly fine but I can easily raise it to 0.40 and beyond without any oscillations. On APM2.6 0.15 was about the limit, why can my P be so much higher?

Many thanks for any help

Thanks for testing. Could you attach a dataflash log (ideally with the LOG_BITMASK set to logging-while-disarmed) and/or a tlog from the failed accelerometer calibration?

Hello Randy

I’ve attached the bin log for when I was undertaking the calibration. I turned on logging whilst disarmed.

I’ve put the latest beta on there and I also tried disconnecting the external compass, but no luck. Still works absolutely fine on the stable version though.


Hi Gareth,

It’s hard to answer your question on the ability to run higher rate gains without oscillation. I had a quad which experienced the same thing. It never really flew well on 3.2, probably because it had really high vibrations, which required very soft vibration isolators, which allowed the Pixhawk to move around a lot. On 3.3, I found I was able to increase the gains about 2-3 times, and it flew much better. I think it mainly has to do with some IMU filtering changes that went in for 3.3. It’s allowed the Accel/Gyro data to filter out noise better, while still allowing control. The oscillation you experienced with lower P-gains on 3.2 might have been due more to vibration, rather than just the capability of the airframe.


Hi Robert

Thanks for your suggestions. Unfortunately this is on 3.2.1. Whilst the kP thing is anomalous my main problem is the accel calibration because at the moment this is completely stopping me using 3.3. If you have any tips for that I’d be very grateful.

Many thanks

Sorry for taking so long to find and look at the logs. Nothing immediately jumps out at me as bad. The 2nd IMU’s Y accel value is a bit noisy but that shouldn’t matter. I see you’ve got the logging bitmask set as well so it’s logging while disarmed.

In this case it doesn’t look like the accel calibration was being done. The log is only 34 seconds long and the board is flat the whole time.

Can I ask, when you do the accel calibration, you’re using the mission planner or AP2? By the way, there’s no need to worry about the compass during the accel calibration, it won’t matter what’s done with it.
So if you’re using the MP, you’re going to the Initial Setup >> Mandatory Hardware >> Accel Calibration screen and pushing just the top button right? Then it asks you to hold the board in 6 different positions (flat, left, right, nose up, nose down, on it’s back) and then after all that it gives you a failure message?
Is the message one of these two:
“Insufficient accel range”
“accel[0] not healthy”

If you respond here, I’ll be quicker to pick it up from now on, promise!

similar issues here… Mission Planner (titlebar) build 1.1.5781.347.85) Accel cal is skipping steps!

Accel cal worked (or so I though?) just fine until I recently updated to 3.2 (or higher?) in an attempts to get Lidar working.

push any button on level… VERY occasionally will stop on LEFT side, but most often after displaying left side, jumps right to RIGHT side before ever hitting a button.
Then it will do it again on NOSE DOWN…jumps right past to nose up so cal never passes

so right now I can not arm as I can not get through Cal without failure.
Reloading firmware and re-installing MP hasn’t helped.
I even hit the arm button to make sure tiny motor pulse vibrations were not effecting the Pixhawk
Ideas where to go from here?


This happens to me toe hen I try calibrating my Pixhawk accelerometers… It worked once but now it won’t… It will skip a step and then fail. My Pixhawk is only about 2 months old and has about 12 flights on it. I even updated the firmware to the newest after getting the new firmware message and that didn’t help either. Another odd thing is if I connect to mission planner and then disconnect I won’t be able to connect again unless I power cycle Pixhawk. Also I can’t ever connect by picking Pixhawk on the com port. I have to select auto every time or it won’t connect… Everything worked great in the beginning. I think mission planner updated in the past 2 months but I can’t remember for sure. Clearly something happened… I think the issue is with mission planner somehow, because my Pixhawk on my x8 copter works and flies great… My only issues are when I try to use mission planner… Andropilot on my android phone won’t always load the map for some reason also but everything else in the app works fine… Any of he other apps wont work at all for some reason… Pixhawk works and flies great but it seems all the computer programs and android apps are extremely buggy for some reason… Aldo I’m using genuine 3dr Pixhawk and parts I’ve ordered from 3dr.

Every great once and awhile Pixhawk won’t arm due to accelerometer mismatch according to the android app. That’s what initiated me trying to calibrate the accelerometers and finding out about mission planner skipping steps without me clicking on the button. I power cycled Pixhawk many times and kept getting the error. Then I just left it sit with the battery connected with the led flashing yellow and the android app saying accelerometer error for 3 or 4 minutes and all of a sudden it made a tone the led went green and it flew fine… No issues after that for awhile. Then it happened again. Power cycling didn’t Help, I couldn’t calibrate the accelerometers due to mission planner skipping steps so I just parked the copter on the shelf. 3 days later I took it to go flying along with my laptop in case I needed to try using mission planner and it worked great again… I plugged in the battery for the first time in days and within 25 seconds I got a green led, it armed and flew fine. I ran about 6 batteries thru that x8 copter that day and not 1 issue. It worked every time I plugged in the battery and after the 1st flight I had Gps locks in 5 seconds and I was in the air in 10 seconds…

So it’s real odd how I get these errors and then I park it and few days later it works great… Mission planner won’t though… Nothing I do will allow the accelerometer calibrating to work. It just keeps skipping a next step without me clicking next and then failing. I can’t ever connect to mp unless I set it to auto and once I disconnect I can’t ever reconnect without power cycling Pixhawk…

If anyone can help please do… I just want to enjoy this stuff not fight and argue with it every time I want to use it ya know?



Mine finally stopped skipping… BUT…
I played around A LOT trying to figure out what was causing the skip.

I’d reloaded MP 1.3.2. Then back to 3.3 without the issue returning (curently at 1.3.33 build 1.15820.11240)
I just opened MP to get that version… and sure enough an update pop-up came up (which I DID NOT do)

It seems like in the end, the SD card was the issue.
I pulled the card, looked at a couple log files…a few wouldn’t open.
I’m assuming crashes where the battery got disconnected abruptly… caused son formatting issues.
After formatting the SD card in an external reader…I haven’t had the issue since.
But it sounds like a legitimate reason for the MP to hang on you as well, just like any other 'puter waiting for some hardware to communicate.