Unable to arm

Hello, I’ve been working on a HK-HJ 650 build for a couple of weeks using APM 2.6/mission planner software. I have a fly sky ts6 Transmitter, Emax 4 in 1 30A ESC. I have everything hooked up, ublox gps/compass, sunny sky 480kv motors, APM power module, 4s 4500mAh battery. I did my calibrations per the instructions on M/P and even looked at some instructions on youTube. My motors calibrated well, compass and radar ok, but when i try to arm via Mission Planner I get the “RC not Calibrated”. I have calibrated the radio 25 times. Looked into the parameters. Had to change channel 3 because the minimum range was too high and channel 4 the min was too high. I did this and hit write parameters and all looked good. recalibrate my radio and nothing changed. went back to the advanced page, the parameters were as I had reset them. They just weren’t written to the APM. As I said, the motors calibrated ok. But when I disconnect the battery and plug back into MP I can’t arm the motors.Can anyone tell me what I am doing wrong? Thanks for any advice!

So after playing around a bit, uninstalling the APM software and reinstalling, recalibrate the ESCs, I was finally able to arm the quad via the planner and R/C. Problem is now after I plug the battery in and the motors make their music I can arm but the motors won’t spin.
I might be overlooking something but I can use some guidance to point me in the right direction.

Are you by any chance running BLHeli on your ESCs? When you power up the craft (connect battery), do you hear the ESCs initializing (usually some sort of tone is heard from them)? I have a similar issue on Pixhawk with Turnigy Plush nfet 30a ESCs flashed with BLHeli. Sometimes none of the ESCs initialize at power up, sometimes just 2 or 3 of them initialize, and thankfully on occasion, all 4 initialize (otherwise I wouldn’t have had a flight yet!) Its been suggested that Pixhawk is putting out too high a voltage on the PWM signals (someone mentioned 7 volts on another post where I picked this info up), when the voltage is supposed to be 5v. This is causing some types of ESC to go into bootloader mode on power up, instead of allowing them to boot the f/w properly. Not sure if APM4.5 has this same issue, but sounds like a possibility - certainly worth checking! The only way to check the voltage on the PWM (motor signal) outputs though, is to use an oscilloscope. As far as I know, not all ESCs are programmed to have bootloader mode acessible to the servo cable connection (some have special programming pads which need to have power applied to allow bootloader to be invoked). I know on the recent BLHeli versions, the f/w has introduced a new bootloader ability which will eventually allow programming via the servo cable - this means you can potentially involke the bootlader mode by applying a certain signal to the servo cable at ESC power up, and its possible that this is what’s now happening with the PWM signal from Pixhawk (and potentially APM also).

On the Pixhawk (which I have on my quad), there is a safety switch which you have to press to start the ESC initialization. You have to do this before you can arm the craft - don’t think the APM has this switch, but I ended up disabling this safety feature and removing the switch altogether, as by having this enabled, the only way I could get the motors to spin after arming, was to press this switch very quickly on powering the craft. If I didn’t do it quick enough then Pixhawk refused to initialise the ESCs when I did press the safety switch. Bit of a nightmare! So there are definitely issues with ESC compatibility somewhere with the APM firmware. Maybe worth having that servo signal voltage checked also, and listening out to see if your ESCs are starting up correctly.

I have the e-max 4 in 1 esc (30 amp). Was able to arm the quad after calibrating the esc’s multiple times. However, my motors aren’t spinning at the same speed either. when I arm and throttle up, 3 motors spin then the 4th won’t start till I give about 50% throttle. So, I recalibrate the esc’s again with the same results. But’ it isn’t always the same motor that has that problem. I do get the beep from the esc’s when I power up and the motors give a little twitch. I’m thinking it may be the parameters but don’t know which to adjust. Anyone with any ideas?

Oh, I am running the SimmonK f/w

Nimetzz1987, I believe that your esc is SiLabs based, and as a result it doesn’t run SimonK firmware. Instead, I believe it runs a manufacturer bespoke version based on the original SimonK code, but ported to SiLabs. SimonK code runs only on Atmel based escs.

Thanks Paul, i was just going by what was written on the documentation
That came with the esc. At one time I was able to arm the quad and spin
The motors. After calibrating and calibrating I am finally able to arm the
APM, however now the motors won’t spin. I have gps lock and solid red light
And when I connect to APM Planner or mission planner everything seems to check
Out ok. I think it’s the esc’ because I am not getting the tones after I plug
The battery into the apm. Calibrated all 4 at once and
Also individually. I am about ready to try another set of esc’s. Any