UDP Connect broken with 1.3.41


I use to connect via UDP on my Navio2-Pi board.

Connection was OK with 1.3.39 but latest update broke it.

Something is wrong with the UDP connect dialog, listening port is replaced by continuous <<<<<

I revert to 1.3.39 to restore UDP connect, if I accept upgrade to latest 1.3.41, dialog broke again.

W10-64 latest update on my computer. It is not a keyboard glitch, same broken dialog without keyboard.



couple of questions.

do you have more than one network adapter connected? please try with just one.
also check windows firewall isn’t blocking it.

Thanks Michael,

I was using direct ethernet connect to the Pi (Wifi internet sharing): 1.3.39 OK, 1.3.41 Broken

Since, I managed to connect Pi with Wifi adapter to my network. UDP connect OK with 1.3.39, broken with 1.3.41

I had a try without Firewall, UDP connect still broken with 1.3.41


Hi All,

I am having a similar problem although the local port dialog looks normal. Worked a few days ago on 1.3.39. After update UDP connect no longer works. Firewall is disabled. Qgroundcontrol connects on the same ip addr / port combo.

Many thanks,

Reverting to 1.3.39 doesn’t fix the problem in my case. I’m running 1.3.39 from a freshly unpacked zip file in a separate directory. For both 1.3.41 and now 1.3.39 I cannot cancel out of waiting for the UDP connection and need to restart Windows. The log shows a scrolling list of HUD messages as attached…

Many thanks,

My problem has gone away. I renamed the Mission Planner folder in “My Documents” and restarted 1.3.41. It prompted to run the wizard as it thought it was a first time run. I cancelled this and tried to establish a UDP connection which is now working fine.


Thanks for the tip.

1.3.41 UDP connect is OK.


1 Like