Ublox neo 6m did not recognize by apm 2.8

Hi, i purchased new ublox neo 6m(module with out compass) for my quad. I connected it using 4 pin headers and a mini plug to apm. But mission planner and apm did not recognize the neo 6m. And I tried to connect using usb to serial pl2303 but my win 10 pc did not recognize the device driver so I can’t access the neo through u-center. I tried to connect through mavserial pass but when I click the icon mission planner did not respond. How to make it active and workable for apm 2.8. module detects gps signal very quick and no issues with the module.

Thank you in advance.

you probably have a problem with the connection. Did you connect the tx pin to the rx and the rx to the tx ?

I checked more than 5 times.

Vishnu Prasad V P
Mob : 9562055650

you need an external compass to fly an APM 2.8 in auto mode…
Why the MOBILE NO:
./am from KTM.

In my apm it has built in compass. So I purchased a module with ublox 6m
firmware. But it is not recognize by the apm. Phone number is coz of my
mail footer option. Thanks for your reply. From TVPM.

Vishnu Prasad V P

The built in compass does not operate well if the board is close to high power cables. Hence, please use an external compass.

Appreciate your interest in this topic. Actually I connected far from these
noise making components.

Thank you


It is close to the battery !!! -> High currents flow in the battery -> Hence, compass will not operate properly !!

1 Like

Thank you very much for the information. I moved the battery. Plz check it.
But from some days some how my drone motor working like a missing
motorcycle engine. Motors are jercking and can’t fly up to the air. I don’t
know the issue.

Vishnu Prasad V P

Did you calibrated the ESCs ?

Reade the documentation to find out how.

1 Like

Ys sir, everything is fine now. But my current issue is with the gps and compass. Coz the offset value of the compass is too high. I will upload a pic to you. Thank you very much for your time.