UAVCAN only displays two Node IDs at a time

I have 2 CAN devices, HereFlow and Here3 on a Cube Orange. Watching Michael Oborne’s Ardupilot Developer conference 2021 presentation, I wanted to follow how UAVCAN Inspector can be used to debug CAN devices. When I first connected I had ID 10 org.ardupilot:0 and ID 124 (something like) com.hex.flow, but ID 125 was not showing. Both devices are working. I powered down, disconnected the HereFlow, and then reconnected and this time I had 10 org.ardupilot:0 and 125 showing. Is there a reason only 2 Node IDs can be displayed at a time? What is Node 10 org.ardupilot:0?

check in “inspector” to see if you can see anything more

Inspector has the same. I was able to replicate your demo looking at Magnetic Field Strength.

Michael, I tried this on another copter with the same setup and got the same result.
In this case CAN1 was Flow and CAN2 was Here3. I saw ID 10 and ID 124 in UAVCAN. Then when I switched Here3 to CAN1, I saw ID 125 and could monitor the Magnetic Field.
It seems like it is a bug, right? I am using MP 1.3.75 and APM Copter 4.1.1.

ill need to confirm this, as it should be showing all of them, up to say 100 nodes

I think I know what happens.
You connected your devices to two different CAN bus ports.
SLCAN displays devices only on one selected CAN bus. This is selected by the CAN_SLCAN_CPORT parameter. Try connecting all peripherals to the same CAN port, and they will show up at once.

ID 10 is the flight controller itself, sending out status data to the bus.

1 Like