UAVcan Dynamic Node Allocation missing in ChibiOS?

Hey there! @rdbachtell and I are curious what happened to dynamic node allocation in ChibiOS? It’s very useful when setting up a Zubax GNSS. Any info on when it will be incorporated back into a build? Thanks!

@vosair what do you mean its missing in ChibiOS. Dynamic Node Allocation has been available in Ardupilot for a while irrespective of the platform. Please elaborate on your issue.

Perhaps I missed something. There use to be a parameter to set to dynamic node ID but hasn’t been there for some time, this wasn’t related to OS but firmware changes. I have had to set static node ID on all of my Zubax GNSS modules and when I tried to set up an EPM gripper via UAVCAN Pavel informed me that the gripper was not set up to set static node ID and that Ardupilot no longer supported dynamic. In any case none of my CAN devices are recognized until I set a static ID. Please let me know how to set up dynamic ID. I am using 3.7 master.

Thank you for your time,

As a footnote, I just checked the Ardupilot UAVCAN setup wiki and it states:

UAVCAN driver for Aurdupilot do not support auto node numbering in current version. All nodes should have the ID explicitly set.

1 Like

@rbachtell it seems that the Dynamic Node Allocation has not yet made into a stable release. But the current master does support it.

1 Like

Thank you for the attention to this matter, I know I represent a very small percentage of users. I have been using latest master and don’t see a parameter to select dynamic node allocation. I remember from previous versions when it was implemented that a parameter had to be selected, perhaps the process has changed. At any rate I can’t get my UAVCAN gripper to be recognized on the CAN buss.

Thanks again, RB

@rbachtell can you try latest master and see if the Dynamic Node Allocation works. Dynamic Node Allocation is enabled by default on current master. There are additional functions that have been added, such as using ardupilot as an SLCAN adapter (like zubax babel), to setup and check attached UAVCAN modules.

1 Like

also note that dynamic node allocation only works if you have a microSD card

Thank you for helping out, I installed latest master and still can’t get the EPM gripper to respond, this could be unique to the gripper. I will be receiving a new GNSS2 in the next few days and I’ll give it a try. There is no documentation I can find for implementing Ardupilot as a SLCAN device and nothing I tried in that regard worked either. I tried connecting the UAVCAN GUI through a Cube Black with no luck.

Thanks, RB

The card in the Cube???

I just received my new Zubax GNSS and can confirm that dynamic node allocation does indeed work. Works all in the background with nothing up front except normal CAN setup and compass calibration. The issue with the gripper must be in the gripper firmware, I will contact NicaDrone to see if they can help. If the SLCAN is implemented perhaps someone could give me some instructions as to how it works.
Thanks to the development team for continued support and enhancements to what has to be the best firmware available.

Cheers, RB