UAVCAN and BBBmini

Hi everybody,

I would like to start using my ArduRover (with BBBmini) communicating the periferals with UAVCAN.
I’ve read a little bit about and most of the tutorials says that it is necessary to enable CAN direct on Mission Planner. However what I have on Mission Planner is:

I would like to know, how I should proceed. (Write code or something else)

Any help is welcome :smiley:


@amandabianchi Hi, Linux UAV-CAN should be supported with ArduPilot. ArduPilot will try to open an interface called can0 .

Please check this in your BeagleBone Linux console to setup the can0 device

sudo modprobe can
sudo modprobe can-dev
sudo modprobe can-raw
sudo ip link set can0 up type can bitrate 1000000
sudo ifconfig can0 up
sudo ifconfig

Best regards


Hi Mirko,

first of all thank you very much for the answer.

My first idea after trying to configure the CANBus on Mission Planer was to read the code, but I was trying to find out the problem in the wrong place (CAN.h and UAVCAN.h). So I decided to enable the CANBus folowing a tutorial about CAN on BeagleBone Black. So I also followed earlier the same steps you wrote me to check and set a “can0” (with other Baud Rate).
Using the command “ifconfig” I was having it (now as well):


I checked now what I have on my board at /ardupilot/libraries/AP_HAL/board/linux.h and that’s what I’ve got:

I don’t know why it is different since I’ve done the step by step to install the ArduPilot.
I’ll change it manually and try again.

Thank you again



at first I’ve tried to rewrite the code on the library, as I said, but it was not succesful. So I reinstalled my ArduPilot to have the latest version and followed the steps to setup the can0 device.
I’m still having the same Mission Planner window (without CAN parameters).

My ardurover version is now: ArduRover V3.4.0-dev (b95fe2b8)

@mirkix do you have some idea what I should do?

Any help is welcome :slight_smile: