Two stages stop in Loiter with video

My newly configured quad flies really well on 4.1. I only see one strange behaviour, when from 10-12m/s i bring the pitch stick to center the aircraft starts the braking than lets go a little than brakes again. It looks like a 2 stage stop. Sometimes it does it even 3 times. Brakes—>release—>brakes—>release—>brakes to complete stop.

22 inches props

If you want an immediate break, then you can set LOIT_BRK_DELAY=0
It could be overshoot on PIDs, send on-board logs (*.bin files)

Can’t get the file from the cube at the moment and mavftp downloading is slooooooowwwww.

Video with LOIT_BRK_DELAY = 0
What i don’t like is the fact that for small movements is very aggressive in braking but when it has to stop from high speeds it stops than releases than stops again abd overshoots stopping point by some meters.

I would like to see one single command for braking when it comes to a stop from high speed, not braking—>release—>drift—>brake again a bit.



Seen the exact same thing with ours, large hex running 30" props. As you mentioned, mainly see it when it coming to a stop from high speeds, the craft almost feels like it’s skipping on the air. I don’t believe we’ve seen this on a previous craft running pre 4.1 firmware but I could be wrong and don’t have a way to confirm currently. We’ve started using poshold as we prefer the feel of it and the braking ‘feels’ smoother but understand that loiter is a lot more tunable.

3.7 was behaving exactly the same.

Try these settings:

Already tried to play with all of them.

LOIT_BRK_ACCEL greater to what is now put a lot of stress on the mechanics and still brakes in 2 stages
LOIT_BRK_DELAY <> zero makes the problem worse, the 2 stages are more evident
LOIT_BRK_JERK Should make a difference if moving the stick during brake which we don’t do

What i am trying to achieve is a smooth 1 stage brake without drift when sticks released and i just can’t. The aircraft doesn’t brake well in my opinion, it brakes and release the braking and drifts. I am sure i am overlooking something and the software can be tweaked to my needs but at the moment i can’t find a proper tune maybe @Leonardthall could help with some magic :slight_smile:

I wonder if some PSC_VELXY_FF would help? Let’s see what Mr. Hall has to say.

Maybe my tuning is not as good as it should be?

This is not primarily a loiter setup or position control tuning problem. You can see that your attitude control is not perfect:

There is a 10 degree overshoot on the initial breaking that results in the aircraft slowing down more than it should and the position controller compensates by asking for less lean angle. There is also a 5 degree error in the forward flight during the acceleration.

I see this when aircraft have soft propellers or up tilted arms especially but I can’t quiet tell from the video if either of these things are relevant to your aircraft. You may get an immediate improvement by doubling your I term relative to your P term on roll and pitch to help the controllers take up the load a little quicker.

Looking at your tune you may get better tune if you set up the harmonic notch filter and then increase INS_GYRO_FILTER set to 40 and the roll and pitch D term filters set to 20.

This is an attitude control problem primarily but similar things can be caused by alt hold and pitch working with each other to skip or bounce the aircraft. I would suggest you see if you can improve the attitude control tune as I describe above and test again.

Hello Leonard, thank you for your great help. I am afraid i have both the issues you indicate, tilted up arms and plastic foldable t-motor blades.
Do you confirm the following:
Actual values

Should become:

On both Pitch and roll.

After setting harmonic notch and setting filters you think i should run an autotune or better tune it manually?

Do you advice on having flat props and not tilted up arms?

Will try everything adviced and report back, thank you very very much.

Tilted up arms are for aircraft that have crappy flight controllers where you are happy to be able to just hover in perfect weather. (I won’t tell you how I really feel :slight_smile: )

Yes this is correct. It helps the aircraft quickly take up the additional constant loads.

If possible yes. There is absolutely nothing good about tilted up arms/propeller disks, so there is never an excuse for that.

Soft propellers blades reduce the shock loads on the airframe and motor in particular so this is a trade off.

I generally do both but if the aircraft autotunes well then that makes things easy.

Ok thanks, didn’t know tilted up arms are bad, would have designed it flat if i knew.
Thanks for all the advices, will do my best to tune it as soon as the weather clears.

Yeh lots of people make that mistake. It all comes from the early DJI aircraft. But even DJI have sorted out their flight controllers so they don’t need it any more.

Have you been able to solve this?

Actually not really, did everything Leonard advice, including straight arms but i still have a 2 stage stoip, no matter what i try.

Can you post .bin logs of flights that you have done after fixing the stuff @Leonardthall said?

Update. @ Corrado_Steri

I have something similar with a 9 Kg quad, 28inch Poly Carbon props and 190KV motors. The quad flew perfectly well in Stabilized but stopping in Loiter was an unstable mess. After some testing I found that reducing PSC_POSXY_P from 1.0 to 0.3 made a huge improvement. Maybe for bendy Poly Carbon props, PSC_POSXY_P should be reduced as the props get bigger and motor Kvs reduce??

After this change there was still a small twitch at the end of the brake that was fixed by reducing LOIT_BRK_ACCEL from 100 to 50. With LOIT_BRK_DELAY = 0 the quad now stops from high speed in a smooth stable manner.