Twitching Backwards when collecting IMU data


I am new to quads, but RC heli’s, Electronics, programming etc are nothing new to me.

However, I’ve been looking at this all day and can only come to the conclusion this issues only happens when collecting IMU data, maybe the overhead is just too great to log and control together?

I have built an X frame Quad, D2830-11 1000kv Brushless Motor, Turnigy Multistar 30 Amp Multi-rotor Brushless ESC 2-4S, 10 x 4.5 Props, AMP 2.5 (HobbyKing Version), UBLOX LEA-6H GPS, External Compass, 433Mhz GCS Link.

CompassMot = 3% when I checked it.

I am now trying to look at vibration issues.

I have done 3 tests today in an attempt to prove that the twitching is only when logging IMU data.

Worst Test
Logging ATT - CTUN - CURR - D32 - DU32 - EV - IMU - MODE - MOT - MSG
I have tried removing MOT from this combination and it was the same.

Logging ATT - CTUN - CURR - D32 - DU32 - EV - MODE - MSG

Needs tuning, perhaps a few slight twitches but nothing as bad.
Logging ATT - CTUN - CURR - D32 - DU32 - ERR - EV - GPS - MODE - MSG - NTUN

I have submitted 3 video’s and all three logs to support this.

I have read that IMU, NTUN, and MOTORS Logging does have a significant overhead, however the result is not validated with an expected outcome of doing so.

Just a thought whilst writing this, maybe I should log PM?

Do you think the vibrations are OK, should I move onto Auto Tune and accept the twitching is due to the logging of the IMU data or do you think there is something wrong here?


twitches are most often caused by glitches on the radio input but I don’t see that in the ATT message’s PitchIn.

IMU glitches can also be caused by a blown 3.3V regulator: … ed-problem

It could be ESCs but that’s slightly unlikely because it’s twitching only in the pitch direction (i.e. pitching back) which would mean that two ESCs would need to hiccup at the same time.

Thanks for the reply.

I will check the regulator tonight and report back.

I did some more log analysis and found that the AngBst pluses at the same time, could this shed anymore light on the issue?

I have tried to google this but found nothing conclusive yet.



OK, so I checked the 3.3v line and all is OK (after I re-looked at the video and checked the compass wire (GPS is 5v)).

So my issue is not this.

Any other ideas?