Turning radius in FBWA

Today, I made the first flight of Cessna 170with Ardu Plane 4.0.6.


After takeoff, I tried to turn in FBWA.
The aircraft tilted, but the turn did not make much progress.
I also pulled the elevator, but the turn did not proceed just because the altitude went up.

Is it necessary to set parameters when the turning radius is large in FBWA?


@miw01 that google drive link requires login. can you set that to public access?

Hi, basti.

I tried to change the link mode.
Can you tty it?

You should repeat the radio calibration or check your TX.

The aileron input is calibrated with RC1_MIN 1024, but the values of your transmitter stop at 1310. So you can reach only half the bank angle of LIM_ROLL_CD 4500 = 22,5°. CTUN.Roll is almost exactly 22.5°.

@miw01 what @Rolf said: using only 207 ms of the calibrated 406 ms RC roll stick travel is what limits your bank angle to 22°. got any dual rates active on your transmitter that weren’t active during RC calibration?

Dear Rolf and bashi,

Certainly, I set Dual Rate for manual mode.
I’ll try without Dual Rate on this week end.

Thank you.

You also should set Q_ENABLE to 0, because the Cessna is probably not a VTOL

Dear Rolf,

I used this pixhawk mini for QuadPlane.
But the motor size is too small,
so I got Cessna 170 for new QuadPlane.
I’ll add lift motors.

Thank you.

Fine, I just didn’t want Arduplane to switch to QLAND without lift motors.
Many successes

Yesterday, I tired without dual rate.
And it works well now.

Thank you!

Today, I tired another UAV, Avanti S (FreeWing) + Pixhawkmini + ArduPlane 4.0.6.

Last week, I tried first fight, and its radius was large.
I checked out that I used dual rate as same.

I unset it, and it worked well.
2nd Flight
3rd Flight

Thank you.

@miw01 that’s a nice plane you’ve got!


Next, I’ll try to install ArduPlane to FreeWing F-14.
Perhaps, next spring.

I was searching this subject. I have the same original issue Miwa had. Very little authority over control surfaces while in FBWA. I noted your thoughts on radio calibration. I have dual rates on my radio. Should I calibrate on low rates or high? Seems like if I did so on high rates then was flying in low rates that could be the problem? I can be full left and it barely turns. I can’t fly anytime soon so just trying to syke this out before I go out again. thx

imho you should absolutely know what you’re doing, have a rough concept of what each flight mode does and, most importantly, of what you want to achieve when adding dual rates while using arduplane in any mode other than MANUAL. you shouldn’t try to fix a sub-par linkage geometry, tuning issues or an unsuitable choice of flight modes by setting your RC travels away from what they were during calibration.

your actual turn radius depends on airspeed and bank angle: image

so if you now add 30% rate reduction after radio calibration on full travel, in FBWA you’ll decrease your max bank angle demand form say 45° to 30°. this will almost double your turn radius at a given airspeed.

I always calibrate at/to the high or maximum rate.
I use different rates on my rc controller, in fbwa, to achieve different plane behaviors as has been described above. Lower rates gives a more docile, but stable, behavior. Ill fly a lower rate sometimes for various reasons… Sometimes ill let a non-flyer play in a lower rate.
One time I didn’t realize I was in fbwa mode (thought I was in manual) on takeoff on a large, fast plane in medium rates. Was the maiden for the plane, so I wasn’t familiar with expected flight behavior. Barely cleared edge of runway before slow liftoff (at high speed), was rolling so slow that I remarked “wow, these flight surfaces don’t have very much effect”. Flew a couple patterns with large radius maneuvers before I noticed my radio switch on fbwa. Flipped to manual (can’t recall if I flicked the rate switch too) and WOW! …plane came to life. Heh heh. Oops.
…ps. I am proficent at flying fixed wing planes in manual modes. Many years/planes experince.

I wouldn’t consider myself proficient at flying in manual modes, but I have a few planes without flight controllers that I’ve managed to keep in one piece.

In OpenTX I set up a dual rate/expo that is only available when I’m in manual flight mode. I have another switch so I can go between a low/medium/high rate, but as soon as I change out of manual all the rates go back to 100%.

Yea when I’m in FBWA it’s almost dangerous I simply do not have enough control over the control surfaces it was all I could do to turn the plane around back towards me. It does a fantastic job at smoothing out flight especially in windy conditions I just have to figure out how to have more authority while in FBWA. I would have thought there is an adjustment in the full params list that would allow some flexibility and adjustment on this rather than do a lot of fooling around with custom mixes / rates on my Taranis which probably would take me several days to figure out. The radio is great it has amazing options… perhaps too many as I often feel I’m in a menu Bermuda triangle!! lol Anyway there’s so many adjustments to ‘plane’ via mission planner I can’t believe there isn’t one for this. Basically I simply want to turn down the rates for pixahwk controlling it.

Could you share a log? Sounds like a poor tune on the PIDs.

Don’t use dual rates in FBWA mode. That will only make the situation worse as you cannot command the full roll command angle (i.e. LIM_ROLL_CD).

Actually I don’t have a log and I am starting over on my plane as I had a lipo go up in flames toasted my whole plane!!! It was my fault I accidentally set the charger to charge a 3 cell when it was 2. Dang it!! :[ But to your point I never did ‘dial in’ the pids I never got that far it was flying with the stock pids. I was flying a SIG Seniorita. Ordered a kit gonna build it again. I will try auto tune next time [ or look for recommended pids ] perhaps this will take care of the FBWA issue. Good point on the pids thank you.