Turbine + Governor Start Sequence

@bnsgeyer Bill, refer to this:

In my opinion the safest is to let the ECU do its job, so if start up goes bad by disarming the copter you should be able to trigger the automatic cool-down sequence if needed. The only problem that might arise is if engine fails the start, and the pilot keep waiting for rpm-rise without disarming immediately.
Keeping the throttle signal to idle would prevent the ECU from starting the cool down sequence (for which the thr-off condition is required). But, if the situation has gone this far, the engine is probably already fried.
Anyway, power cycling the ECU normally triggers the cool-down sequence if ITT is high.
If none of the above have worked, you can disarm (so thr-off) then re-arm while keeping the turbine start auxiliary switch pulled, this should trigger the manual motoring for a couple of seconds or so. Then repeat the above cycle till ITT is below 100degC.

@Shotfire it depends in which phase you are experiencing problems (switchover? fuel ramp?) key parameters are, in sequence: pump start value, engine min flow and fuel ramp. I would contact TS for more detailed recommendation though. In my experience with the current brand of engines we are using, pump start value has the major effect for tuning this.

@Shotfire i could probably take what Ferruccio has done and put it into 4.1.5 with the ardupilot commit requirements and build a binary for you. It sounds like this should meet your needs? I will then rebase it on master and get it into 4.2. What board are you using.

@bnsgeyer Orange Cube.That would be great, but don’t hurry. Our weather is going down hill late tomorrow, below zero. I probably won’t be able to test it till later in the week.

@Ferrosan Thanks for the suggestions, I’ve tried all the normal stuff and it would either hot start or not start, even worked with TS on settings. I eventually sent it back to them to replace the gear box bearings and when I received it back it was a total flame thrower. I decided to go down the black hole to understand in detail what all the setting do and how they interact. I finally fixed it today by changing some of the RPM settings which nobody talks about and those that do say don’t touch them, well, for high altitude starts that was the answer. It now does a beautiful start without the starting EGT exceeding the idle ECT which is what a properly tuned turbine should do.

@Shotfire I’m glad to hear you managed to sort out the start-up!
In the end air/fuel ratio is the problem, and since the start-up phase is totally “open-loop” in this little engines, you can get it right by either managing the fuel metering or changing the rpm thresholds.
Maybe you already have it, just in case I would strongly recommend this:
https://www.xicoy.com/catalog/product_info.php?cPath=1_22_48&products_id=362
This is the most useful and only tool to fine tune the engine and monitor it by setting up alarms in the radio.

@Ferrosan Thanks, Yes I have several, I fly the turbines with a Jeti DC-24, fuel flow sensors and several other sensors. Arducopter monitors both flight battery and turbine battery, two RPM sensors one going to the DC-24 and the other to the FC.

@bnsgeyer Hi Bill, Just checking if you had a chance to incorporate the governor changes, I would be able to test it tomorrow and over the weekend?
Thanks!!

@Shotfire Here is a link to the firmware. It is ArduCopter 4.1.5 with the Turbine start feature built for Cube Orange. This feature has already been merged in master and will be available in 4.2.

@bnsgeyer Thanks Bill, I just downloaded it.

1 Like

@bnsgeyer
@Ferrosan

Edit: Never mind problem was on my end

There is something strange going on, maybe I’m just doing something wrong.

To teach the ECU the right PWM’s,

  1. The first thing it wants is ThrottleUp and TrimUp (FullPower). I can make that work by arming, having the RSC set to ThrottleCurve and raising the collective pitch to max.

  2. Next it wants ThrottleDown and TrimDown (FullStop). To do that I have to disarm, that works.

  3. Next is wants ThrottleDown and TrimUp (Idle). After I disarm from step two I cannot re-arm, to give it the Idle PWM, it always gives me MotorInterlockEnabled no matter the position of the InterLock switch.

@Shotfire Sorry Doug. I guess I gave it to you but didn’t describe how to use it. So it works off an aux function which means you have to set the RC option to 161. Therefore when you flip the switch for that RC channel it will raise the throttle to full and decrease it back to minimum for you automatically without having to touch the collective.

@bnsgeyer

Thanks Bill, I figured that part out but got tripped up on the InterLock settings in the radio. Now that’s fixed.

Just did a quick test in a hover about one foot high and it seemed to work fine. Now I just need to fine tune the ThrottleCurve.

Great! Glad to hear it worked for you.

@bnsgeyer

Is there any version for the OrangeCube that includes the Turbine Start feature and your new governor that would be reasonably safe to test?

No. The only branch that has both at the moment is master and soon to be 4.2 beta