Tuning X8 Heavy Lift - Tuning for Payload

I’m working on a new build that’s a little trickier to tune than my previous Arducopter aircraft and after experiencing some unusual and inconsistent performance, I wanted to see if there might be something I’ve missed along the way.

Aircraft specs and information below:

  • X8 coaxial octocopter
  • MAD MOTORS MAD 6X 12-II 170KV arm sets
  • 22x7 carbon props
  • Cube Orange
  • Here 3 GPS
  • 2 x 6s 16000mah Lipos in series for 12s power

The frame is a self-built frame that’s just a simple symmetrical plate + tube design. It’s somewhat overbuilt and is very stiff. The payload (gimbal and camera) is fixed to a plate that has ‘alpha gel’ vibration isolators to try and reduce any vibration being transmitted to the payload.

  • AUW (no payload) = ~9.5kg
  • AUW (with payload) = ~14kg

I’ve followed the tuning guide (as always!) and ran into some issues along the way:

  • Initial flight showed the temporary landing gear vibrated dramatically, leading to oscillations. Elected to re-build landing gear to reduce vibrations.
  • New, much stiffer landing gear still oscillated (seemingly from prop wash) but significantly less, reducing Pitch and Roll PID made aircraft much more stable
  • Alt-hold test to prepare for autotune resulted in Z oscillations. Landed and reduced PSC_VELZ_P by 50%, Reduced PSC_POSZ_P below the minimum to .4 - no change in oscillations.
  • Set PSC_ACCZ_I and P to suggested values in tuning guide - Alt-hold stable. Observed that MOT_THST_HOVER was very low (.128 or so)
  • Followed harmonic notch guide and set to 97hz - aircraft flew well
  • Autotuned axis one at a time - aircraft tune felt quite ‘tight’

I was reasonably confident in the aircraft at this point, so I replaced the landing gear with the payload (which has its own integrated landing gear) with a spare battery in place of the camera as dummy weight and conducted another test flight.

I observed some vibration from the landing legs, but it seemed to be performing quite well.

Landed after an uneventful flight, and checked motor temp etc. all was well, so decided to finish the batteries with another flight.

This time, the aircraft oscillated dramatically on takeoff, it looks as though it was originating from the landing gear, but it was hard to tell.

Tried again in order to grab some video and see if I could determine the origin of the sudden vibration, same result.

What’s got me stumped, is the change in behaviour between the first flight, and the two little hops. I didn’t change any parameters between the two flights, but it flew very differently. I checked for some kind of mechanical failure, or anything coming loose, but couldn’t find anything.

I’ve attached the log of the ‘successful’ flight, and the two small hops where dramatic oscillations were observed.

Is there something I’ve missed that may have caused this behaviour? This is the first large aircraft I’ve tuned, so my knowledge of tuning and log analysis is very limited. Any advice or suggestions would be appreciated!


I would say the base frequency will be about half that → 48Hz

I’ll check over the log and see what I can find.

Ok, so I might eat my words on the base frequency.
It is odd though, there must be a lot of resonance causing such a large peak to show up at 90 to 100 Hz like that. The base frequency will still be down around 40 to 50 Hz for those size of props, but it’s just so obscured at the moment.
I would try to reduce vibrations more, the non-damped IMU will be affected. You can see it’s Z axis bibrations are getting into the danger zone and clipping even just started.

The Harmonic Notch filter wasnt doing anything but it was nearly correct, just set these:
and tweak these

There’s a bit of a physical yaw bias, CCW motors are working slightly harder than CW motors to correct for some arm or motor mount twist.

For the Yaw oscillations I would lower these, even though the oscillations might be helped a bit if you can sort out that motor mount twist
ATC_ANG_YAW_P,6 (nearly half)
ATC_RAT_YAW_P,0.7 (just down a small amount)
and see how that goes
You can always reduce the ATC_ACCEL_Y_MAX to about 18000 or 16000 too.
If there’s still trouble, try increasing
MOT_SPOOL_TIME,0.5 to 1.0 or 1.5

Thanks for that!

This is tricky. I suspect vibrations are coming from the payload, but the payload is not something I can change. Perhaps I can add some weight to the legs to try and shift their resonant frequency? They seem to be acting a little like tuning forks at the moment.

I’ll have a look at this and re-level the motors.

I’ll change those parameters and give it another shot tomorrow and report back.

Some of the flight controllers have IMU foam resonance at 100Hz. Worth checking the non-isolated one.

Squeezed in a quick hop today in relatively still conditions. Wasn’t able to fly ‘around’ too much, mostly hovered to confirm the previous vibrations had been resolved.

I added some TPU 3D printed feet to the landing legs, re-levelled the motors and changed the parameters above.

The new parameters appear to have resolved the vibrations that made the aircraft barely controllable and the landing legs appeared to vibrate significantly less with the added weight on the end.

I observed a new Z oscillation somewhere around 10hz that made it look a little sketchy in flight, but it was controllable.

It’s obviously hard to tell where this might be coming from. I suspect the payload is the source. I’m conducting these test flights with the gimbal locked in the forward position, and a dummy weight in place of the camera. The gimbal has some ‘slop’ in the locked state, so It’s possible the source of the vibrations.

Here’s the log, would be interested in people’s insights.


You haver a pretty good Roll Rate oscillation going on. It can be seen in the Motor Outputs also. Pitch is there too but not as dramatic:

Did you set these back to default after changing them with no improvement?
“PSC_VELZ_P by 50%, Reduced PSC_POSZ_P”

Review these, the ratio is not typical.

In that log the 46HZ base frequency is more prominent than earlier, so I would set:

Try reducing ATC_RAT_RLL_D to the same as ATC_RAT_PIT_D

No - I didn’t return those to default.

I’ll tweak PSC_ACCZ_I and PSC_ACCZ_P back to what’s suggested in the tuning guide - That may have been part of my troubleshooting.

I’ll do that now and duck out for another flight now.

Ok, returned PSC_VELZ_P and POSZ_P to stock setting.

Corrected PSC_ACCZ_I and P to suggested value in tuning guide

I also implemented @xfacta’s suggestions.

Seems the oscillations are more prevalent now. Didn’t switch out of stab mode. Log attached.


Lowering P and D values for Roll and Pitch by 10% seems to have resolved the oscillations, and it appears to be flying ok.

The tuning guide suggests dropping the values by another 25% to reach my final number, is this to provide a little more headroom to the value that results in oscillations?

Also, what’s generally considered an acceptable level of oscillation?

Here’s the log:


I would reduce these next, then re-assess
Autotune on a quad-X8 seems to come up with 10inch quad range of values, as if the props are half of their real size. I’m guessing you ran autotune at some stage because of all the very specific values of things with decimal places.

You can safely set

Yes, I ran autotune.

I’ve built and flown a handful of arducopter multirotors, but this is the first x8.

In most cases, I reached an acceptable tune just using mostly default settings and auto-tune. It seems x8’s behave differently enough that autotune isn’t great at honing in on a good tune.

I’ll tweak those parameters and give it a shot.

Seems to be flying nicely now.

I’ll load it up with the full payload in the next couple of days. Is it worth doing what’s suggested in the tuning guide?

Here’s the log from the most recent flight.


The attitude control, and I think everything else, looks quite good. Some copters this size dont get that good even after autotune or lots of manual tuning.
I might be putting myself in danger here, but it’s like the QuadX8 format is inherently more stable than a plain quad.

I would probably adjust
ATC_INPUT_TC,0.15 → up to about 0.22 or 0.25 with a load
just to slow down the RC input response, so the copter is not attempting aerobatics with the payload onboard.

You can lower the Accel Max values based on that formula. Just dont go too low, like below 60% of existing values, or the copter wont be able to respond properly to disturbances and it will become too “sloppy”.
If you notice that effect just increase them somewhat.
Single digits and decimal places dont matter in this case so just round them up or down to the nearest thousand.

The Harmonic Notch Filter is working great. Leave it as-is for now and check the logs after the payload test. You might be able to set
and leave it alone.

What’s NOT working is current monitoring. Voltage seems good.
Check your

1 Like