Tuning of 25kg OctoQuad X8

I find tuning this thing tricky.
The tune is based on many autotune results - some decimals deleted during manual changes.

Please see test in some 6m/s wind. (most of the test this is “tailwind”)

The propeller sets are level top and bottom are hard mounted, but each arm could be rotated, and despite what logs may suggest … they are level.
The frame is based on Foxtech D130, with four 22Ah 6C packs in 2S2P configuration. U11 KV120 motors and 27x8.8" propellers.

Events to evaluate:
at 60s : Since upgrading to 4.0.3 - the “takeoff assist” is “harder” , I expected to “feel the machine” with skids on the ground, it jumped up and surprised me, also yawing unintended.

180sec: POSHOLD: I do some hard roll input left and right, (with wind from “rear”)
233 sec: same tests in LOITER
284sec : the same test in POSHOLD, heading wander off for a while.
492sec : descend in STABILIZE, getting very uneven sink rate
529sec: descend in ALTHOLD is much more smooth. (which can be seen clearly in motor outputs, and yaw)

The wind was from behind, and from below (up a slope/valley.)

@Leonardthall - please take a look on this…

at 60s : It looks like you had a 20 degree yaw command in there from holding the yaw stick too long when arming. So this is why it took off faster and yawed after takeoff.

How are you enabling the motor interlock? It doesn’t look like you have it on a switch…

You have LOTS of noise there mate. Unfortunately you don’t have the logging turned on to provide me any more insight. You can get the harmonic notch filter in there to help a bit.

There isn’t much I can do with the information you provided above. You haven’t really asked a question other than what happened when I took off.

This is what you should set your logging to when tuning:

It’s almost like you’ve got a couple of the motor order and prop directions wrong, or maybe there’s a bit of weight imbalance - unsure about this, but something will need to be corrected.
Are you using a Kore carrier board?

Anyway I’d definitely set these params right away:
And you other params are not too far wrong at all but I’d set these anyway:

There’s a lot of Compass warnings, I would:

I think usually the compass health warnings are when it disagrees with GPS heading, or multiple compasses disagree with each other.

Set the logging that Leonard recommends and do some gentle test flights.
You might even be able to move onto Autotune.

EDIT: I meant to say that there doesn’t appear to be much interference with the external compass but there is with the inbuilt compasses even though you have them disabled.
This graph shows throttle Vs compasses - so the Compass/Motor calibration might help a bit.

Sorry, I do not know what happened with the logging, my notes show bitmask 180222d
I do not use interlock, will removed it completely.
Motor order/prop direction is correct, props (not motors) balanced - to me it seems that lots of the vibrations are caused by excessive PID’s.
I’ll gather new data soon.

Please see new test flight with proper logging.

This is what your motors are seeing:

You have a huge 26 Hz signal in the roll axis. What is strange is that it is very clean in the roll axis only.

The roll and pitch tune appears to be reasonable.


I would suggest you start by halving the roll PID parameters and see if that stops the oscillation.

Thank you, much appreciated. The strong-wind oscillations always happened in the roll axis.
I can’t promise it will be done before I return from vacation, (going on vacation on Wednesday) - But I will try, then post my findings here.

I found it very puzzling the PID’s alone should cause that in roll axis, as it is a symmetric X frame.
So I found origin of the problem:
The carrier board (long & narrow) was nicely softly suspended, but the narrow nature and high CG could make it “roll” - so I added damping on top, to prevent said roll - and got much nicer data:


This is only the change to the damping. No PID’s changed.
I had to disable prearm checks, as successful compass calibration (onboard-type) was performed, then rebooted, then it still complained about compass.

Please observe that yaw overshots a lot at big inputs.
I did some aggressive pitch/roll to provide better data for further tuning suggestions.

Well now you have less noise on Roll and more on Pitch. The frequency is now 65 Hz. You are now at what I would consider just on the edge of manageable noise levels.

If you go through the process of setting up the Harmonic notch you may get this down to decent levels of noise. Then you may be able to get a decent tune out of roll and pitch.

I would suggest dropping ACRO_YAW_P to 2 or 3 with the lower acceleration on yaw. Also I can see that yaw basically isn’t tuned so I would revisit that once you get roll and pitch sorted.

Hi Leonard, sorry for bother, but how you get this frequency message from the log?