Trying to use older software and won’t load into FC

I have been building drones for falconry training. I have a setup I like using fw AR 2.5 AP 3.3 AC 3.2.1
It has worked perfectly with the Scottflys telemetry build out. With the new HK pilot it will not let me load this FW. It loads then the FC gives me a red light. I can load FW 3.3 but the build changes and I don’t want to have multiple build to figure out issues. Is there any way to get this FW loaded? I have gone back and purchased pix32 Flight Controllers with the same issue. Is there a specific version of mission planner that will allow me to load 3.2.1 or is it the FC not recognizing the firmware?

You can load 3.2.1 on a Pixhawk from the current version of Mission Planner. Which FC is this “new HK pilot” unit you speak of?
BTW-Frsky telemetry has been supported natively now in Arducopter for a few years (of course not in 3.2.1) essentially making Scottflys solution obsolete. You don’t need a Teensy any longer for example.

The HK pilot is 2.4.8 I believe. I have tried the older version and they will load 3.3 but when you put anything older In them they red light. Thanks for the reply I don’t have a lot of experience in the different firmware versions. I have built what worked and now the software has become outdated.

The HK pilot is hobbykings pixhawk FC. I have had good luck with them since 3DR doesn’t make them any longer. I have also used Radiolink Pixhawk FC and they are even better.

OK, I have one of those sitting on the bench. 3.2.1 loaded no problem, just tried it.

Wow I must be doing something wrong! Would you be interested in selling it or trade for a new HK? I updated to the latest version of mission planner and still getting the same results. When I move up one firmware to 3.3 it will load just fine. Did you load AC50 3.2.1? I am in a jam with this issue. Thanks for taking time to help me out I wish we could talk it would make it easier.

Was it a radiolink or HK?

HK, I don’t have any Radiolink products. Version as shown. You should probably just update all your stuff, there have been many, many improvements since FEB15!

Ok I’ll give it one try. If that doesn’t get it I’ll change over like you said.

When you do check out this project for Frsky telemetry on your Tx. It’s excellent and well maintained.

This is my HK pilot I have 2 same issue. Tried to load after loading I get red light! I have changed SD cards to see and that did not help.

I have the exact same FC. Here it is loaded with 3.2.1 in the Armed state ready to go! I don’t know why you are experiencing a problem but just ditch 3.2.1 and move on.

BTW-The cable you see here from the Telem 1 connector to the Rx Sport is all you need for Frsky telemetry. I haven’t used a Teensy for this purpose in years.

That is a nice build and no more teensy would be nice. It is a lot more info than I need yet it would work.

If you are in the US and really want this FC with 3.2.1 loaded PM me. But I would recommend updating all your stuff instead. Latest OpenTx and latest Stable Arducopter. No doubt you will have config issues to work thru but worth doing in the end I would say.

Not sure either. I just have a lot of drones out there using that format. I can load 3.3 there is a major change at that point but not sure what. Where is the best info on the new version it has been awhile since I have started over?

Yea, you are 4 Rev’s back on 3.2. 3.6 is the latest stable and there would be no reason to choose an earlier version. The Wiki is the place to start.

Thanks for all your help! It’s nice to find the people with the answers.