Troubles with APM 2.5? and External Compass

Just wanted to say a quick hi as I’m a new member, and seek some advice on a new setup I am working on for a kids project. In short, we have a 3DR APM 2.5 (I assume because it has the internal compass), and the external compass and GPS module.

When trying to set everything up, and calibrate the compass (Selected as APM with external compass in Mission Planner), I am able to calibrate the external compass no problem. The screen shows all the movements just fine. However, the HUD and map are using the internal compass on the board. No matter what settings I put in the unit, it never navigates off the external, only the internal… yet will only calibrate the external, and not the internal.

Does anyone have any suggestions?

From what I understand the APM can only use one compass. To use the GPS compass you need to cut a trace on the APM.

So that was my first thought aw well… but when I pulled the cover off, there are just two pads there that say “Mag”, and no soldered trace of any kind.

Sort of looks like this… just bare copper pads and not a drop of solder anywhere.

Just under the “F” on “front—>” you need to cut the trace. You might not see solder but there is 2 gold pads with a very fine trace between them. You need to cut that trace to disable the internal mag.

I must not have looked at it close enough! I’ll take a look later on tonight when I get home… It’s just weird how it shows up perfectly in calibration, but not in nav.

Here is the original pad where you would expect the trace… nothing there

For giggles i etched it out with a razor just to be safe…

It is apparently a 3DR v2.6.1… but if memory serves me… the 2.6 does not have a onboard compass

Im at a loss here :confused:

Sorry I though it was an APM 2.5 not a 2.6. So it will only use the external compass. So then you dont really have a problem or dont know what the problem is.

So here is where it gets interesting… If I unplug the external compass, and even the gps antenna for example… the internal compass still works… If it’s a true 2.6, as it was sold as, and is printed on the board… then it shouldnt have any compass at this point… this is what is most confusing to me lol

Compare the first two pics, If you look at the board’s, just below the solder pads for the internal compass you should see that one has a set of solder pads and the other has I chip installed. That chip is the internal compass.

The hud will update it’s heading from gyro inputs, which will look like its using an internal compass. To check that, power up the board with its front facing in different directions. If each time the hud says it’s starting at north then it’s not using any compass just the gyros.

If you have a volt meter, check the wires going to the external compass and see what voltage is powering it, it’s possible the 3.3v regulator has died.

Alright… so i powered up the apm without the external compass, and measured voltage… spot on 3.3volts. I then tried a compass calibration, and nothing showed up when i tried to calibrate. I then power cycled it facing 3 directions, and it did always show north when it powered up, and responded when i turned it.

I then plugged the compass line back in, and set it to use the external compass… the external compass calibrated perfectly and took the offsets… but still, does not respond to being turned… but picks up the gyro’s being moved. The compass coming from the GPS unit only has two wires, so i would imagine it’s getting its power from the GPS antenna.

I have yet to see anyone else have a problem like this lol