Trouble with osd apm 2.8

ello all, i have an apm clone the chinese 2.8 actually it has been on another quad and on this build for years now, maybe 6 years so far i updated the fw on it a year ago to the last fw version that ran on the aging apm( before this update the problem am facing didnot exist) -in my setup earlier and now i connect the telemetry port tx and rx to minum osd running arducam 2.2- , a couple of days ago i wanted to play around with the quad, i noticed that osd displayed no gps lock though the gps took a couple of minutes … i bought the pc out to the field and just as i plugged in the apm 2.8 via usb to pc the mission planner showed every thing fine , disconnected the apm 2.8 from pc every thing seemed fine on osd , i flew in all modes fine and rtl back with less than 1m , i landed disarmed disconnected the battery, i reconnected the bat and the same problem repeated no matter what i do or wait no gps lock and no battarey voltage or current appear on osd, once i connect to pc things go fine! now i researched the following that flight and tried parameters modification on
i didnt find in full parameter list SR2 , to check if it is related to causing this problem.
changing the parameters to those in list didnot work! first can some one explain this?? and had any one solved it??

findings, serial 0 is for usb serial so better not mess there ; serial 1 is the telemetry port for osd , varying parameters there didnot work the time flight mode horizon and compass pointing are all working but battery voltage and current only after arm ang gps lock only and only after connecting via com port to pc; access to uart 3 or 4 seems to need hardware jumpers some times or even modding the code running on apm fc

just as a final correction!! uart 0 is used both for telemetry and for micro usb communication to pc… while port1 is for gps.

here was the solution to my problem