Trouble with calibrating ESC and testing motors (SOLVED!)

Hi all,
I am in need of some help, I just finished building my second quadcopter which is running the 2.1 ProfiCNC cube on the Mini carrier board

I am running APM copter 3.5, and a 4-1 BLHeli 35A ESC and using a Spektrum DX9, with a Here2 GPS, I have my ESC plugged correctly into the Main ports on the mini carrier board (I followed the layout of the full size carrier board that the cube came with) and I have all 4 motor signal wires to the signal pins, and the common ground and 5V on the correct rails to my knowledge.

The problem is that I cannot get the motors to spin when they are armed, I also cannot get them to spin while testing motors with Mission Planner

When I try to calibrate the motors, after powering on with the throttle high, the GPS lights go into the regular blue and red flash, I unplug the battery and plug back in and then press the Safety Switch to begin the calibration process, but the motor’s never make any sound after pressing the safety switch and they don’t go through the calibration no matter what I do.

When I arm the motors with the TX, the GPS goes solid green indicating that it is ready, (again, after pressing the safety switch) but the motors never spin when I throttle up

And when I attempt to test the motors on Mission Planner, the same thing happens… the copter arms but the motors dont spin

The thing that gets me is, the GPS flashes red and blue when I try to spin the motors, and then it goes back to green but I never get any kind of an error or warning on MP at all, it just acts like nothing even happened.

I also have no other warnings at all, although once or twice I did see the word “SAFE” come up on the main screen of Mission planner near the instrument panel (the horizon panel) but it disappeared quickly and I did not see it again.

Hopefully I have explained this clearly and somebody can give me an idea of what to check, I’m definitely lost here…


Post a picture of your motor connection. My opinion is you have signal and ground reversed.

Another question: Do the motors make any sounds at any time? HINT: If power is applied to the ESCs, and if the motors are properly connected to the ESCs, regardless of how the control signal wires are connected, the ESCs should go through the boot sequence up through the battery cell count tones. The last single tone in the sequence indicates the ESCs have a valid control input signal. This tone will not be made unless the control signal inputs are connected properly and the safety switch is pressed.

Yes they do make noise when I plug the battery in, it beeps 3 times just like my other aircraft does (which flies fine) which is part of my confusion

@ThePara here are those pics!

I have it set up exactly the same as my other aircraft which uses the cube with the standard sized carrier board… the motor signal wires are hooked up to signal 1-4 and the power and ground are being used on the #4 pos and neg power rail.


After doing some truthing with a multi meter, it turns out that the Mini Carrier Board does NOT correlate with the full size carrier board… on the full size board, the signal pins are the bottom rail, the 5v is the middle rail, and the ground is the upper rail (if you’re looking at the FC straight on)

on the MINI board, it turns out that the signal wire is the TOP rail, the 5V is the middle, and the Ground is the bottom rail (again, if you are looking at it straight on, with the cube oriented on top)

so this issue is solved… re-arranged my motor wires and my Receiver plug in, and the motors spin and ESC calibrated as they were supposed to just fine!

1 Like

Here is the pinout for reference, if anyone else has troubles

Glad I steered you right. Have fun now :slight_smile:

1 Like

Yes that was a good thought, however the trouble isn’t over yet… I have everything wired up to spec and the drone is now acting like I have a motor or prop on wrong or hooked up in the wrong 1,2,3,4 spot even though I don’t… this is weird