Servers by jDrones

Trouble setting up TF-Mini


(William) #1

I’ve run through setting this up quite a few times and keep hitting a wall (not literally).

I hook it up and set:
SERIAL5_BAUD = 115
SDERIAL5_PROTOCOL = 9
RNGFND_TYPE = 8

At this point it works and the distance shown in Mission Planner under Initial Setup >> RangeFinder looks right.

My sensor is faced forward though, and each time I set:
RNGFIND_ORIENT = 0

It stops working.

Here are my full parameters:

RNGFND_ADDR = 0
RNGFND_FUNCTION = 0
RNGFND_GAIN = 0.8
RNGFND_GNDCLEAR = 12
RNGFND_MAX_CM = 900
RNGFND_MIN_CM = 30
RNGFND_OFFSET = 0
RNGFND_ORIENT = 0
RNGFND_PIN = -1
RNGFND_POS_X = 0
RNGFND_POS_Y = 0
RNGFND_POS_Z = 0
RNGFND_PWRRNG = 0
RNGFND_RMETRIC = 1
RNGFND_SCALING = 3
RNGFND_SETTLE = 0
RNGFND_STOP_PIN = -1
RNGFND_TYPE = 8


(ppoirier) #2

@wsmeyer
When you switch direction to forward - RNGFIND_ORIENT = 0 - you instruct the system to go from Altitude detection to Proximity mode.

In this mode the signal is displayed as the ‘‘RADAR’’ screen.
To invoke the radar screen you have to CTRL-F within mission planner and select proximity like here:
http://ardupilot.org/dev/docs/code-overview-object-avoidance.html#reporting-to-the-ground-station

Hope you will ‘‘see’’ now :wink:


(William) #3

Thank you!

That was it, and setting PRX_TYPE = 4


(MerkaTony) #4

@ppoirier

I have done post #25746 in which i have configured the TF Mini as proximity and it works, only the problem comes on GPS modes and when the sensor is beyond its maximum measurement distance the Radar Screen goes from the existing measurement 4-5-6 meters, to 1m and the whole platform can fly in any direction besides forward.

Any thoughts on this one?