Servers by jDrones

Trouble Parsing Arducopter 3.6dev log

I’m using APM Planner 2.0.24 and noticed that it fails to parse the most recent Arducopter log files. I get this error:

I haven’t been successful in building a new version from github yet on Windows. Is there a more recent compiled version available for Windows that may handle the new log files?

Building now…should have something ready for you shortly.

Thanks. I’ll test it out as soon as you’re ready.
(Can it be compiled for 64 bit? That’s what I was trying.)

Yes, 64-bit. Here you go:

That worked! Thanks!

I also tested your new version on a 1.3 GB log file and it worked fine now. It had troubles with a 321 MB file in the past on Windows (worked on Linux). Nice work!

I wish I could take any credit, but it’s been the fantastic work by @billb and @Arne-W --I’m just the “build guy”.

1 Like

Great work @billb, @Arne-W and @carpy! The plotting capability works very well on large (>1GB) log files.

@rrr6399 nice to hear that it works for those really big log files - during redesign I only tested against a 230MB log file. Hope you like some of the new features like cursors and presets.
@carpy - only the build guy?! You are the one who provides usable versions to everyone! Thank you for that!

1 Like

Hello,

would it be possible to have the 2.0.25 version for Windows 32 bit ?
Thanks !

Try this guy and let me know if it doesn’t work and I will see what I can do.

https://discuss.ardupilot.org/t/apm-planner-2-v2-0-25-for-windows/23955

I download this file “apmplanner2-installer-win32.exe” and receive this error :

OK, thanks. Let me look at it when I get a chance.

@lucamax Try this installer for Windows 32-bit:

Thanks carpy, I’ll let you know ASAP if it works .

Still have the same message error

Ok, I’ll look a deeper and get back to you.

Ok, try again please (sorry I don’t have a win32 system):

Hi, a different error now

Oh man, that sucks. Let me look again, we having fun yet? :slight_smile:

Servers by jDrones