Trouble building code with waf on ubuntu - couldnt find arm-none-eabi-ar even though it's in $PATH

hey! I’m attempting to build ardupilot code. I’ve followed this guide here, installed the ubuntu script, etc etc and I get this error while trying to build.

“Could not find the program [‘arm-none-eabi-ar’]
(complete log in /home/tarik/Documents/ardupilot/build/config.log)”

after the error, i tried to troubleshoot by manually adding the compiler to my path as well, here’s that.

and have also confirmed that arm-none-eabi-ar is in there, still no luck

Anything else i can try? this is on ubuntu 16.04.

1 Like

Fixed. I think my ./bashrc and ./profiles had some weird previous settings that i didn’t want to touch for my own sanity (100% going to break something i forgot about) so i just did “sudo apt install gcc-arm-none-eabi”. even though i had the build essentials installed, this installed the correct packages in the right places so now ./waf configure works properly.


On my Mac M1Pro, arm-none-eabi-ar is already on the Mac. I just added /Applications/ARM/bin to my PATH and it worked.

Thanks a lot man.
It worked pretty well.

I solved this issue by doing so ./waf configure --board XXX –ekf-single on My mac