Trigger using pixhawk, arduplane 3.8.3

Hello, I’m trying to make a trigger for a samsung NX Mini camera with a Pixhawk 2.4.8, I’m using Arduplane 3.8.3, and my Mission Planner is version 1.3.50 …

The problem I have is how to set up my Mission Planner, I followed the instructions on this page “” but I can not configure the Mission Planner to do this.

The instructions on the site tell me to configure the RC10 output, but this option does not appear for me, only the SERVO5, SERVO6, SERVO 7 … SERVO14 options appear.

I put the SERVO5 option and connected the camera cable to the Main Out 5 port, but I did not succeed. Below are some pictures of my settings.

I also tried to put the SERVO9 option and I connected the camera cable to the Aux Out 1 port, but it also did not work.

LIst of the parameters that I modified:

One thing I noticed is that if I connect the camera cable to Aux Out 1, with the pixhawk turned off, when I turn on Pixhawk the camera starts taking pictures automatically without stopping.

A member of the facebook group, Oliver Volkmann, shared with me a document with the details for cable assembly for a Sony a6000, I followed the same steps and worked perfectly with my Samsung NX Mini, below I leave the document to help other members.

To access the link you need to be a member of the facebook group “apm 2.x & pixhawk (all versions) controller group”