Tricopter tilt/tail servo not working

Could somebody please take the time to give me some advice?
I need some advice to get my beast off the ground.

I have been working and learning this stuff off and on for 2 years now, and it is time to get a project off the ground.

I have done everything to get my tail/tilt servo working, or at least I think I have…

Let me explain what I have done…

I’m running a APM 2.6 W external compass.

The rear rail is powered from the balance plug off a 14v 4s, through a filtered step down converter at 6V

The tail servo is plugged into #7 as per the instructions, but no movement after before, or after arming. The props do spin up when throttle is applied.

From what I understand the tail servo should move, after arming. It has power, and the metal geared servo is not faulty.

I just pulled the servo wires off the #7 pins, plugged a new servo in , and no go. I also tested the installed servo, with a servo tester, and it works no problem.

I ran a multi meter on all center power pins, to check for proper voltage to the servo outputs. 6V No problems.

Now, I used to get a check board voltage warning in MP, but after troubleshooting all possibilities I found that it was a faulty USB cable. The warning is now gone, after a new cable is being used. APM 2.6 is not faulty.

I read on another forum that a guy was getting the same issue, but after disabling the pre arm check his tail servo worked for him. I have disabled pre arm, nothing.

Now the questions…

Is there something in advanced parameters I should be looking at?

I went in there and looked at RC_7, and it is enabled, but everything else is a mystery at the moment.

Should I use another servo output?

Is it a setting on my TX? (Futaba 9C)

I am running a FRSKY 2.4 TX module, along with a FRSKY D4R II RECIEVER in CPPM mode.
The throttle does spin up all 3 motors, so #1, #2, and #4 signal pins are working, but not RC_7

Where do I start to trouble shoot this thing?

Does anybody have a list of things I could check to make it work?

I am sure it is just a setting, but it is driving me crazy, and giving my wife fuel to keep saying this is all a money pit. Lol

The fact you can spin your motors indicates your APM is arming correctly, so your problem won’t be in that area. But your tail servo isn’t responding. Could be several reasons for this.

  • Improperly flashed firmware.

  • Servo plug for tail servo plugged in wrong.

  • Bad connection between your RC Rx and the APM on the yaw channel.

  • Bad APM output on channel 7.

Unfortunately I don’t think you can remap the channel 7 output to another channel. You are stuck with it.

From what you describe there’s nothing in the Advanced Parameters that would create the situation you are seeing.

You should verify that you are actually getting a yaw signal into and out of the APM. Using Mission Planner, hook up your APM to your PC and have a look at the Failsafe page. It will show you in real time what PWM signals the APM is both seeing on each input channel and putting out on each output channel. Check that you see a yaw signal on both the input and output (you might not see an output signal until the APM is armed). This will help you further narrow where the problem is.

Thank You,
I will look into the failsafe to look at things in real time.

Ok went into Failsafe, and looked it all over, and there is not any output from the apm on the #7 channel, or anything else, but when throttle is moved, I get an output on #1, #2, and #4.
So that would explain the props spinning up after being able to arm.

I suspect now that it is the FRSKY D4-RII. I updated the firmware in the receiver, to the new frame rate to get 8 channels out, but it seems the APM, and the receiver are not talking together in CPPM mode.

Exit the D4-RII and enter the D8R-XP and no CPPM. Time to make cables. I suspect this is the problem.

If it is, then I will mark it as solved, and hope that this little thread will help somebody else who has run into this snag. I am keeping my fingers crossed. If , a “no go” , out goes the regular APM 2.6 in favor of a new APM 3.1 mini FC.

Hi I’m running AMP 3.1 mini and Futaba receiver 2006GS and a 14SG radio
I have the same problem servo works through servo tester, but not from 7 on the APM board
I have external power to servo from separate battery also regulated to 5v
Anyone come across this before ???

An update to my problem, which is now resolved. :smiley:

Having wired the receiver then the servo, I made a rooky mistake and took the second to last wire out of the motor connector, which is actually no 9 Not number 7. DOH!

36 hours wasted but hay I learned something, check, check and check again. :unamused:

Ok so it seems like the person that started this thread never got his running. I am having the same problem.

Works connected directly to the receiver.
Mission Planner shows yaw radio input.

Ch7 does nothing when armed.

Motors spin up fine.

Only thing i haven’t tried is to reflash.
Has anyone found a definitive solution?

I’m the guy who started the thread, Yes i did get it working, but never followed up… My Bad…

For me, it was always a bad connection coming off of the board to the tilt servo. Check it again with a multi meter.
I think I went to Ch 8 for the tilt servo also.