Tricopter rolls 30 degrees right with good calibration

Hello all! I’m having quite a difficult time figuring out this problem. I’ve had it before, but don’t recall what steps I took to correct it.

I’m running a pixhawk with copter 3.2.1 on’s tricopter frame. I have wireless telemetry and I’m leaving the GPS unhooked while troubleshooting. As the title says, I’ve calibrated the radio and accelerometer. The mission planner hud shows that it is perfectly level, however if I try to take off, it tips right. If I hold onto the bottom of my copter, and spin the motors up a little in stabilize mode (I accept this is a bit dangerous, feel free to scold me), it maintains almost a perfect 30 degree roll right. It thinks that 30 degrees is level, and will compensate if I try to roll it to the correct level position. It really doesn’t want to be level.

I have found that adjusting AHRS_TRIM_X to the minimum of -0.1745 corrects some of this, but it still tries to maintain about a 15 degree roll.

Any ideas? I’ve spent too many hours on this problem, hopefully the community can help track this down.


Please provide tlogs and/or dataflash logs to help troubleshoot your issue.

Alright, I created a quick log. Since it won’t fly like this, I armed it, held it level, spun up the motors, and tried rolling it left to the level position a few times (if that helps interpret the logs any better).

I’m grateful for your time, thanks for taking a look!

Wondering if anyone can help me with this? I still haven’t had any luck correcting the problem. I’ve waited months to repair my baby and I’m dying to fly again. :slight_smile:

had a similar problem.
The workaround for me was to completely reflash the controller by loading the plane firmware first and directly afterwards the tricopter firmware again.
Then complete redo of the setup including a proper esc calibration.

I think in my case the problem was that I moved the controller from a quad to a tri.

Hope that will help you out.



I am having an issue very similar to this except with a quad. I tired to reflash with plane firmware then back to copter frimware (3.2.1) with no avail. Still unsolved for me at the moment. Has anyone else overcome this issue?

I have flown this quad before a long time ago with no issue. The build and wiring has not changed since then. The quad maintains roughly a 30 degree right roll and stabalizes around 30 degrees, effectivly flighing up and to the right continously and quickly. Obviously I am expecting the quad to maintain level flight in one place with minimal input from the sticks. I can confirm this holding the quad in my hand an observing which way it wants to go.

I have calibrated all ESCs, accel, rc, compass multiple times. I have checked all motor directions, and props, their tighness etc. I have tried changing frame type from V to X. I have been stuck on this for months now and plain out need help.

Can you post a .bin log file?
Any reason you are using AC 3.2 ? Is it an old APM flight controller?

Here is the file. Yea i am using AC 3.2.1 because this is an APM 2.6 board and that is the most recent firmware the board can support.

62 12-31-1969 8-00-00 PM.bin (39.7 KB)